Unable to install iperf3 on OpenWRT21.02.2


Thanks for the prompt reply.

I hate quoting myself ...
Neverthesess, I think I have an idea of what happened.

Let me roll back to when I ran out of space in rootfs.

Did not mention it but I got a line that stated:
* parse_from_stream_nomalloc: Missing new line character at end of file!

I solved* the problem by doing some basic gparted on the WD MyBook HDD, that line did not go away. * Not really sure, jury is still out.

Looking around I found a post that gave a solution ...

cp /usr/lib/opkg/status /usr/lib/opkg/status.bak
rm /usr/lib/opkg/status

... which did get rid of the message and as I expected, /usr/lib/opkg/status was regenerated once I rebooted.

No. I missread.
The file is status.bak.
Getting old ... 8^/

But now the problem is that this regenerated status file does not contain the same information contained in the original one.

It seems that this status file contains a list of the all packages installed by OpenWRT at the beginning and from then on.

The problem at hand is that when you want to install a package in OpenWRT and there is not enough room in rootfs to do that, somehow /usr/lib/opkg/status gets corrupted.

See the the last two entries of the backed up /usr/lib/opkg/status.bak file:

Package: hostapd-common
Version: 2020-06-08-5a8b3662-41
Depends: libc
Status: install user installed
Architecture: powerpc_464fp
Installed-Time: 1692295891

Package: libpopt0
ABIVersion: 0
Version: 1.16-2

Just how many entries are missing?

I have no idea.
The system does not automatically backup the original status file before attempting to install or upgrade a package.

Makes sense because it is not needed for the typical OpenWRT installation.

Fortunately, I have a /dev/sda2 image from when I first installed OpenWRT in WD-MBL.

Opening the status file from the image with Pluma shows that the last line number is 1257 but opening the (corrupt) backed up one shows that the last line number is 1748.

What to do now?

Thanks in advance.