Unable to get IP from ISP (Charter)

Issue with first connection to internet:

Unable to get IP from ISP (Charter).
First with 19.07.3-ar71xx-nand-wndr4300-ubi-factory.img and then with openwrt-19.07.4-ar71xx-nand-wndr4300-squashfs-sysupgrade.tar.

Power cycled modem (ISP supplied Cisco DPC3216 DOCSIS 3.0) and router (WNDR4300v1).
Powered down modem and router, powered up modem waited for boot to complete then powered up router just like many times in the past.

Modem port connected to wan port on wndr4300 router with cat5e cable and wired connection from laptop running Xubuntu to router.

After last hard reset (reset button on back of router) with router offline, logged into the web interface and made 8 changes.
-Added password.
-Synced time and date with browser.
-Set SSH Access Interface to lan.
-In DHCP AND DNS> enabled Log queries.
-In Interface>Wan> disabled Use DNS servers advertised by peer.
-Added OpenDNS IPs in Interface>Wan>Use custom DNS servers.
-Changed MAC in Interface>Wan>Advanced Settings.
-Changed Firewall>Traffic Rules>Allow-Ping and Allow-MLD>Action to Drop and then rebooted the router.

Changed to same MAC I used on this router before switching to OpenWRT. It is also the same MAC I'm using on the new Netgear RAX router that I regret getting (the reason for the earlier than planned install of OpenWRT on my old router). But at least it's usable.

Since my ISP is Charter and my modem is a DOCSIS 3.0, I tried with and with out the wan broadcast flag selected.

Prior to the last hard reset, I connected it to my RAX router (wan port to RAX lan port) after reverting the MAC back to default.

It didn't work at first and it was way past bed time. So I started making changes. Going from more logical to less logical, rebooting the router between most changes. Unfortunately I didn't keep notes this time. Didn't expect it to work. Achieved partial success. I was able to connect to some sites but not others. Most likely double NAT at work.

I look froward to any assistance that may be offered and thank you for your time.

Verify with ip -s link that the mac address is correctly applied to the physical interface of wan, and that you have TX/RX packets without errors/drops.
Verify with your provider that the modem is not blocking the mac and ask them if they see anything wrong from their end.

1 Like

Changing the MAC of the router may require unplugging the cable modem and leaving it off for at least 30 minutes, or even contacting the company out of band to release the old MAC. But once you have done that it is simpler to register the default of the new router rather than keep cloning it.

Do check that you're not having layer 1 problems by checking the signal lights on the modem.

A possibly related issue could be that the ISP is relying on a combination of MAC of the DHCP requestor AND the 'Client ID' (DHCP Option 61) for their lease management.

I note that when I WireShark the WAN handshake from a Netgear, it provides the MAC of the WAN port in the option 61 of the DHCP request.

By default, OpenWRT does NOT populate that field.

BTW- You must enter the 'Client ID' in HEX, and the first two characters (i.e first byte) must be '01' (zero one), usually followed by the hex values of the MAC, minus the colons or dashes.
So if the MAC is: AB:CD:EF:01:02:03 The correct Client ID is '01ABCDEF010203'

Client ID is under Network->Interfaces, click 'Edit' on the WAN, then click 'Advanced Settings' sub-tab.

1 Like

First of all I want to thank all of you for taking time to reply. I am grateful!

@trendy
I'm not sure the modem would block the same mac on one router but not the other.
Unfortunately it doesn't look like the statistics option is available for ip to use in BusyBox.
(OPTIONS := -f[family] inet|inet6|link | -o[neline])
When I ran it with out the -s option, I see that eth0.2@eth0: link/ether shows the routers default mac.
No TX/RX packet info shown.
However, under Interface>wan in the browser I see TX/RX packets without errors/drops. Just no IP.
When I look at the network config file, I see "interface wan" shows the spoofed mac and "device wan_eth0_2_dev" shows the default mac. Should these be the same?

@mk24
Since I have to frequently switch between the new Netgear RAX router for internet use and the one with OpenWRT on it, I felt it would be better to keep the same MAC on both.

Signal lights on the modem look good. Link light shows activity.
Same with the router, power light is on solid and green. Internet light on active and green.

@TopDog
Entered client ID as you described before powering down to swap routers. It didn't seem to make a difference.
Decided to try enabling broadcast flag again along with the client ID. This also didn't seem to make a difference.

Have you noticed anything in WireShark that would suggest Broadcast flag is actually needed.
Charter is the only ISP named in the browsers Interface Wan section and somebody went to the trouble to put it there.

Question, I want to provide OpenDNS to the clients on the network.
In doing so I placed the IPs in "Interface>Wan>Use custom DNS servers".
Should the IPs instead, be placed in Interface>Lan>Use custom DNS servers?
And could this be a cause of not receiving an IP from my ISP?

You would configure that under WAN, but first you should try default of accepting the ISP DNS advertised in DHCP, to see if it will connect at all. General philosophy is to start with a default configuration, change only enough to make it work at all, then try customizing more stuff until you break it.

Thank you, I will try that.

And what @TopDog said, since you're trying to clone what the Netgear does, using Wireshark to look at the request it makes vs. what OpenWrt does could be very useful. Ideally use a switch inline with a mirror port configured so you also can see Charter's response (if any).

I would need a switch/device placed inline between the router and modem to capture the request packets correct? Unfortunately I don't have a switch or device that would work.
I did try connecting the router wan port to a laptop running dumpcap to see what I would get. The only thing captured was traffic between the router and laptop as suspected.

It can't hurt, so I'd leave it on by default.

What 'broadcast' does is help with lease renewal. As without broadcast, the default is to send the renew to the MAC of the DHCP server that originally granted the lease. But if that server is offline or unreachable, then you do not get an approved renew, and eventually, your lease runs out and the WAN goes down.
Broadcast enabled means the renew is broadcast and any active DHCP server can reply.

Yes, I use a Netgear GS105E 5-port managed switch with one port configured as 'source', one port configured as 'mirror', and the remaining three are a bridged switch used to connect the 'target(s)'.
So in this case, modem output goes to the source, router to one of the three targets ports, and your laptop running WireShark to the Mirror.

I also use multiple links on the laptop (via USB to Ethernet dongles) so the traffic I record is solely the one from the mirrored port.

I must say TopDog, the detail you provide is quit welcome and useful in my continuing education in networking. Thank you for that.

At some point when I'm able to, I intend to get and create a similar hardware setup to the one in your reply. I've been wanting to do something like that for a while now, but didn't really have any details in mind on how to set it up. Thanks for the insight.

I have a pretty good handle on Windows computer systems. Building, diagnosing, and repairing. I'm the go-to guy among family and friends. But networking is mostly new. I also now spend more time on Linux than Window. So something else I'm learning.

Here is the result of my latest attempts:

-After hard reset:

-Added password.
-Set SSH Access Interface to lan.
-Enabled Broadcast flag. (Disabled is Default)
-Default MAC.
-Powered up modem powered up router.
No IP received.

-Rebooted from browser.
-Synced time and date to browser.
-Changed MAC.
-Power cycled modem and router.
No IP received.

-Synced time and date to browser.
-Added client ID
-Rebooted from browser.
-Power cycled modem and router.
No IP received.

As a reminder on the MAC. It's the same MAC used on this WNDR4300 router prior to flashing OpenWRT for the first time.
Same MAC used on new router I'm currently using for internet access (intend to move the new router to a secondary position until additional bug fix firmware updates are released) so I don't have to try to register and unregister a different MAC each time I swap routers.

Watch the logs and see if there is some info about what is happening, not only whether it works or not.

The point is to find out if the configured mac address on the wan (uci show) is the same as the mac on the running configuration (ip show)

Did you ask your ISP by any chance?

Have been checking syslog and dmesg/kernel logs often but nothing has really stood out. Ntp has complained about a config error at times, but that would be expected with out an active connection.

Is there something a little more specific I should be watching for?

I sometimes see that wan has sent discovery but there's nothing about a lack of response.

@trendy

# uci show
network.wan=interface
network.wan.ifname='eth0.2'
network.wan.proto='dhcp'
network.wan.broadcast='1'
network.wan.macaddr='00:xx:xx:xx:xx:x1'
network.wan.clientid='0100xxxxxxxxx1'
network.wan_eth0_2_dev=device
network.wan_eth0_2_dev.name='eth0.2'
network.wan_eth0_2_dev.macaddr='6x:xx:xx:xx:xx:x6'

# "ip show" only prints the usage for "ip".
# "ip link show" and "ip link" give the same info.
Did you have another ip command string in mind?

# ip link
7: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 6x:xx:xx:xx:xx:x6 brd ff:ff:ff:ff:ff:ff

Contacted service provider, said modem looks good but router does not appear to be connecting to it.

Two different cables used between modem and router.
The one that worked on this router before flashing OpenWRT for first time. and the one that came with the new router.

-Both cables work when connecting router wan port to laptop and older cable works when connecting wan port to new routers lan port. Was able to access internet. Didn't try the new cable for this.

Please use the "Preformatted text </>" button for logs, scripts, configs and general console output.
grafik
Please edit your post accordingly. Thank you! :slight_smile:

Sorry about that and thank for the info on the preformatted text button.

Which one is the mac of the previous working router? Currently the interface is using the 6..6 and the link is UP, so I am not sure why your provider doesn't see the router connected.