Unable to flash TP-Link Archer C2600 V1.1

im was using an TP-Link Archer C2600 V1.1 with OpenWRT for nearly two years.
I recently tried to flash a newer Version of OpenWRT but something went wrong and now all of the LEDs on the Router are constantly on and it seems that the device isn't booting at all. Because restarting the device or holding the reset button wasn't helping I tried to flash the firmware through TFTP.

  1. I downloaded the firmware from the TP-Link Website directly.
  2. I set the IP of my Computer to and connected it to the LAN1 port
  3. I renamed the .bin file to ArcherC2600_1.0_tp_recovery.bin and putted it directly into the tftpd-root.
  4. I started the Router while holding the reset-button.
  5. in the tftpd64 logs i could see that a device with the IP was downloading the firmware (which is strange, because according to the instructions on the OpenWRT website it should be https://openwrt.org/toh/tp-link/tp-link_archer_c2600_v1)

The Router downloaded the Firmware and restarted immediately but it still didn't boot up so i tried it with the other firmwares from the tp-link Website, the OpenWRT-firmware, with other PCs, an switch between Router and PC and with tftpd-hpa on ubuntu but nothing seems to work.

Has someone an idea how i can save my router? ?

(im sorry for my bad english)

1 Like

That suggests that the bootloader integrated flasher rejected the uploaded image, e.g. because of you having provided a wrong regional firmware or maybe because the bootloader hwid might be corrupted. You'll probably need serial console access to debug this further.

Did you try stripping the stock firmware till the occurrence of the beginning of the kernel uimage, and then transferring through tftp ?

Can you explain me how to strip a firmware?

How do i stripe a firmware?

I think I try it via serial console.

According to https://openwrt.org/toh/tp-link/tp-link_archer_c2600_v1 I would need a "Bi-Directional Logic Level Shifter Converter". Can you recomend one?