Unable to flash any firmware on WRT1900ACS V2


First of all, I would like to apologize for my lack of experience which might show in some of the questions here. also, I am not sure if this is the right forum to post my issue.

I have Linksys WRT1900ACS V2

It was working fine until I decided to install some bandwidth monitoring package which I forgot and then I decided to remove. and that's when the problem happened.

the problem started with me not able to access the web interface and I keep getting the message " LuCI - Lua Configuration Interface" and it asks me to download a file.

that problem happened to me before and when I tried "firstboot" it reset the router but still, I wasn't able to access the web interface. luckily I was able to switch to the second partition where I had the original firmware and reflashed the firmware again.

now that is not the case as there is no space.

root@Router:~# df -kh
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.5M      2.5M         0 100% /rom
tmpfs                   250.0M    204.0K    249.8M   0% /tmp
/dev/ubi0_1              23.7M     23.7M         0 100% /overlay
overlayfs:/overlay       23.7M     23.7M         0 100% /
tmpfs                   512.0K         0    512.0K   0% /dev

no space to reinstall packages or do anything.
I tried to reflash the original firmware using mtd it just reboots to the second partition.
tried sysupgrade with original firmware image and with OpenWRT bin without keeping settings, the same story.

the only thing I haven't tried here is to do firstboot on the first partition where I currently have the working OpenWRT which I cannot access on the web and I don't want to risk not having working internet at all.

please any suggestions would be appreciated.

So if I'm understanding this correctly OpenWrt is still running on one of the two partitions and you just can't access it over the LuCI Interface?

Yes, in addition to that the space that has been used in almost everywhere except the temp folder.

To me it looks like something with your Filesystem went wrong. The "tmpfs" partition has 250M of which it uses 0.2M?? Seems a little off. Also that the root partition only has 2.5M.

The only thing I can think off is to completely reset the router and start from scratch.
I would try to boot into the other partition to see if there's something running.

Or enter into failsafe mode and hard reset it.

1 Like

The factory reset option is the obvious one too but I was hoping for anything else I can try since I don't have a contingency plan.
Anyway I'll try and update here.
Thanks ASFP

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.