Unable to establish PPPoE

Hi there :vulcan_salute:
I have an ASUS TUF AX6000 where I've decided to install OpenWrt ( OpenWrt 23.05.3 (r23809-234f1a2efa) ), but I'm having some issues with the PPPoE connection.
My ISP (TIM, from Italy) require the 835 VLAN Tag and provide me a ONT (I've 2500/1000 profile). With stock firmware I'm able to work this out but not with OpenWrt.

I think that I've messed up with the name of the interface or similar.

In the wiki (https://openwrt.org/toh/asus/tuf-ax6000) seems to me that I've to use eth1 interface, but with that on LuCI I see "Network device is not present" error. When I use eth0 I've a timeout issue.

This is my configuration:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdfe:6fea:fd51::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'

config device
        option name 'lan1'
        option macaddr 'redacted'

config device
        option name 'lan2'
        option macaddr 'redacted'

config device
        option name 'lan3'
        option macaddr 'redacted'

config device
        option name 'lan4'
        option macaddr 'redacted'

config device
        option name 'lan5'
        option macaddr 'redacted'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.835'
        option type '8021q'
        option vid '835'
        option ipv6 '0'
        option ifname 'eth0'

config interface 'wan'
        option device 'eth0.835'
        option proto 'pppoe'
        option username 'redacted'
        option password 'redacted'
        option ipv6 '0'

The device page on LuCI:

And the syslog:

Sun Apr  7 00:49:14 2024 daemon.notice netifd: Interface 'wan' is now down
Sun Apr  7 00:49:14 2024 daemon.notice netifd: Interface 'wan' is setting up now
Sun Apr  7 00:49:14 2024 daemon.info pppd[7678]: Plugin pppoe.so loaded.
Sun Apr  7 00:49:14 2024 daemon.info pppd[7678]: PPPoE plugin from pppd 2.4.9
Sun Apr  7 00:49:15 2024 daemon.notice pppd[7678]: pppd 2.4.9 started by root, uid 0
Sun Apr  7 00:49:15 2024 daemon.warn odhcpd[1944]: No default route present, overriding ra_lifetime!
Sun Apr  7 00:49:30 2024 daemon.warn pppd[7678]: Timeout waiting for PADO packets
Sun Apr  7 00:49:30 2024 daemon.err pppd[7678]: Unable to complete PPPoE Discovery
Sun Apr  7 00:49:30 2024 daemon.info pppd[7678]: Exit.

And the configuration from my ISP

  • USERNAME: numero_telefonico
  • PASSWORD: timadsl
  • PROTOCOLLO: PPPoE Routed (defined as RFC 2516)
  • INCAPSULAMENTO: VLAN Ethernet 802.1q
  • NAT: active
  • VLAN: 835
  • IGMP proxy: disabled
  • Routing: unicast traffic

Can anyone help me?
Thanks a lot.

I did not have to create a 8021q device; the config like below works for me

config interface 'wan'
	option device 'eth0.835'
	option proto 'pppoe'
1 Like

Hi! You're my savior, it's works! :heart_eyes:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.