Unable to disable ipv6 - 21.02.3 on R7800 router


I have a new install of 21.02.3 on an R7800 router. Factory reset and set PW. No other changes made. I attempted to disable ipv6 by following this tutorial:

After reboot, ifconfig still shows inet6 references which I believe indicates that ipv6 has not been disabled.

I have reset/retried several times but still no luck. I suspect I am doing something wrong/dumb in the ssh process, but I just don't know what. Any suggestions would be great. Thanks in advance!


Bad news.
Similar topic from the past: Disabling IPv6 on OpenWrt

Thanks for your reply and link to the past discussion of this topic. After reading through that thread, it seemed that the OP was able to disable ipv6, but it was not clear to me exactly how that was done. This seems to be at odds with the posted solution that it cannot be done. This raises some additional questions...

  1. Assuming the code at the link I referenced is not rubbish, it must have worked at some point. It was updated within the last several months I believe. Is this just an instance where the most recent version of OpenWRT can no longer have ipv6 functionality disabled with that code?

  2. Is there an alternative (but not overly complex) way to disable ipv6 (without creating a new build) on the current version of OpenWRT (21.02.3)?

Thanks in advance for any answers/thoughts/input etc..... :slight_smile: