Unable to connect to ZyXEL WSM20 after reset [SOLVED]


I had installed the sable OpenWRT 23.05.0 on a ZyXEL WSM20 and then configured the unit as a wireless bridge according to https://openwrt.org/docs/guide-user/network/wifi/connect_client_wifi#connect_to_client_wi-fi_network

Everything seemed to work fine :slight_smile:

Then, I wanted to try installing OpenVPN according to https://openwrt.org/docs/guide-user/services/vpn/openvpn/client-luci and I probably had a very unfortunate idea there ... :frowning:
After installing openvpn-openssl and luci-app-openvpn, I performed a reboot. I waited some minutes, but the login screen did not appear again. Fearing that something was going wrong, I pressed the reset button on the rear of the unit.
Result: the unit seems to power on, but I am not able to connect to LAN1 port (the same I had always used in the past) through either (the address I gave for the wireless bridge) or (the standard OpenWRT address).

Any suggestions?

Thank you in advance for your help

try https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

Thank you @frollic let me have a look and see if I can unlock the situation.
I will post the update

I decided to go for the Factory Reset > Reset button, because it seemed simpler to me :slight_smile:

Afterwards, I was able to connect to = it seems that it was able to bring the device back to the initial installation of OpenWRT. And I was requested to set up a password = good sign, exactly from the beginning.
Where it seemed to be stuck, is after I tried to load the backup I made earlier today before starting changing the configuration, since it kept showing the message about updating the configuration for quite a lot of time ... when tired of waiting, I tried to refresh the browser, it disconnected, but when I tried to connect to, it was possible and it seemed that the wireless bridge was working properly (it had automatically connected to the router and I could surf the web from a wired connection to LAN1).

Do you think that it should be OK, or shall I reinstall and set it up again from scratch?

Thank you

Anyway, after installing openvpn-openssl and luci-app-openvpn, exiting, rebooting the device, same issue as explained in the post #1, I can no longer connect to

I am wondering if I should have gone straight to configure OpenVPN in Luci, or there is a compatibility issue between 23.05.0 / wireless bridge mode and those openvpn modules ...

Let me repeat the factory reset ....


Just to complete the thread here.
I went through the factory reset, then configured again as wireless bridge.
I went to the firmware selector (https://firmware-selector.openwrt.org/), and customized a build for the ZyXEL WSM20 by adding the OpenVPN packages (openvpn-openssl and luci-app-openvpn).
When the router was upgraded to 23.05.2, I uploaded the settings saved for 23.05.0, and, in the end, it seems working OK as wireless bridge under 23.05.2, with OpenVPN installed.
Now, the issue is to configure correctly OpenVPN for a wireless bridge :slight_smile: (I will write a separate post for it), but I will mark this thread as [Solved], since it seems that 1) I can connect to the device 2) OpenVPN is now there

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.