Unable to compile OpenWrt on Debian 10

Ahoy friends.
I recently bought my Banana Pi R1 to get OpenWRT running on it.
So i cloned OpenWRT using the git, and tried to compile it after selecting the correct CPU.
I also want to use EXT4 as root partition type.

Unfortunately after a few minutes i receive this error, using make -j1 V=sc

Does someone know what's wrong? I almost didn't find anything useful regarding this errors, so i hope someone can help.

# If this is the top-level multilib, build all the other
# multilibs.
/usr/bin/true: DO=all does not exist
make[5]: *** [Makefile:125: all-multi] Error 8
make[5]: Leaving directory '/home/chairman/Dokumente/OpenWRT/openwrt/build_dir/toolchain-arm_cortex-a8+vfpv3_gcc-8.3.0_musl_eabi/gcc-8.3.0-initial/arm-openwrt-linux-muslgnueabi/libgcc'
make[4]: *** [Makefile:11675: all-target-libgcc] Error 2
make[4]: Leaving directory '/home/chairman/Dokumente/OpenWRT/openwrt/build_dir/toolchain-arm_cortex-a8+vfpv3_gcc-8.3.0_musl_eabi/gcc-8.3.0-initial'
make[3]: *** [Makefile:37: /home/chairman/Dokumente/OpenWRT/openwrt/build_dir/toolchain-arm_cortex-a8+vfpv3_gcc-8.3.0_musl_eabi/gcc-8.3.0-initial/.built] Error 2
make[3]: Leaving directory '/home/chairman/Dokumente/OpenWRT/openwrt/toolchain/gcc/initial'
time: toolchain/gcc/initial/compile#0.84#0.11#0.93
make[2]: *** [toolchain/Makefile:100: toolchain/gcc/initial/compile] Error 2
make[2]: Leaving directory '/home/chairman/Dokumente/OpenWRT/openwrt'
make[1]: *** [toolchain/Makefile:96: /home/chairman/Dokumente/OpenWRT/openwrt/staging_dir/toolchain-arm_cortex-a8+vfpv3_gcc-8.3.0_musl_eabi/stamp/.toolchain_compile] Error 2
make[1]: Leaving directory '/home/chairman/Dokumente/OpenWRT/openwrt'
make: *** [/home/chairman/Dokumente/OpenWRT/openwrt/include/toplevel.mk:227: world] Fehler 2

(Moved to the For Developers section.)

1 Like


make clean

make -j1 V=s > errLog.log 2>&1

And add file to topic.

Thanks for your reply.
Here i got the errLog.log file.


I was able to get it running.
Had to set up a virtual machine, running Ubuntu 18.04 or Debian 9 (Stretch), and it has worked fine!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.