Unable to boot recent snapshots on Zimaboard 216

I'm having an issue with the Zimaboard 216 booting the latest x86/64 snapshots. It worked previously, but newer openwrt EFI snapshots just hang at "Booting Openwrt". It doesn't get far enough to show any error so it's been hard to troubleshoot. When booting in non-EFI mode I get a partial output that may be a stack trace, but I'm not able to scroll up to fully see it and read the full output. Is there any grub command line option I can type to increase the console resolution and capture the stack trace? Here's text I was able to extract from a photo:

[

[ 0.402689]

TCP: Hash tables configured (established 16384 bind 16384) UDP hash table entries: 1024 (order: 3, 32768 bytes, linear) UDP-Lite hash table entries: 1024 (order: 3, 32768 bytes, linear)

0.403277]

8.403835]

0.404513] NET: Registered PF_UNIX/PF_LOCAL protocol family

0.405012] pci

0000:00:13.0: PCI bridge to [bus 01]

0.4054311 pci

0000:00:14.0: PCI bridge to [ bridge window

bus 02] [

0.4062951 pci

0000:00:14.0: pci 0000:00:14.0: bridge window [

[

[

0.405824]

[

[

[

[

[

[

[

[

[

[

[

[

[

io 0xe000-0xefff] mem 0x91200000-0x912fffff]

0.406806] pci

0000:00:14.1: PCI bridge to [ 0000:00:14.1: bridge window

bus 03]

0.407198] pci

[io 0xd000-0xdfff]

0.407667]

pci 0000:00:14.1: bridge window

[mem 0x91100000-0x911fffff] 0x0070-0x0077]

0.408183] pci_bus 0000:00

: resource 4 [io 0000:00: resource 5

0.408661]

pci_bus

[io

0x0000-0x006f window]

0.4091311

pci_bus 0000:00: resource 6 [io

0x0078-0x0cf7 window]

0.4095981

pci_bus

0000:00: resource 7 [

io 0x0000-0xffff window]

0.410077]

pci_bus

0000:00: resource 8 [

mem 0x000a0000-0x000fffff window]

0.4105851

pci_bus 0.411095] pci_bus 0000:00: resource 10

0000:00: resource 9 [mem

0x7c000001-0x7fffffff window] [mem 0x7b800001-0x7bffffff window]

0.411613]

pci_bus 0000:00: resource 11

[mem 0x80000000-0xcfffffff window]

0.412134]

pci_bus 0000:00: resource 12

[mem 0xe0000000-0xefffffff window]

0.412655]

pci_bus 0000:02: resource 0 [

io 0xe000-0xefff]

0.413085]

pci_bus 0000:02: resource 1

[mem 0x91200000-0x912fffff] [io 0xd000-0xdfff]

0.413561]

pci_bus 0000:03: resource 0

I've got the same issue on my zimaboard.

It first shows Booting OpenWrt, then hangs with a blank screen with just a blinking cursor.

I didn't have issue last year...just decided to upgrade to the latest build, but now this...

If you try booting the non efi version, can you try to get a screenshot of the stack trace? It hangs for a minute before the crash appears so it might take some time.

I will try it over the weekend.

Did u change anything related to PCI in bios?

I tried adjusting various acpi and PCI aspm settings in the bios but nothing seemed to help.

Does it boot from a USB drive with dietpi or debian live image?

How did u get openwrt in there in the first place?

For initial install I booted from USB and wrote openwrt to mmcblk0 using dd. I can also boot openwrt directly from USB that was written from a PC using dd, but either way the crash still occurs with recent snapshots.

What was OS loaded from the USB?

Just want to see if it is openwrt specific.

Currently running an older snapshot of openwrt on USB from before whatever change broke it. Haven't tried other OS.

1 Like

Zimaboard does not support certain newer x86 instructions, e.g. AVX.

I wonder if if latest snapshot was built with new instructions enabled...

My baytrail-d j1900 works fine with main.

Could this be the issue?

Not very likely, that was a custom build.