Unable to access web interface via Default Gateway

Hi,

I have an TP Link Archer C7 v2 router which I have flashed with OpenWRT yesterday. I have uploaded a quick and dirty network diagram to help diagnosis.
image

I had got it set up with USB tethering on my Android phone by creating a new interface that listens to the USB0 port. I then bridged it to the existing LAN connection to the existing LAN interface that connected to the DLink Router.

I thought that if I just looked at the default gateway when I connected to the internet I could use this to connect to the router but it didnt seem to be the case. Entering this into the web browser gets the "refused to connect" screen

I then disconnected the phone and the TP Link Router from the DLink Router and tried to access 192.168.1.1. This did not work either. Probably because i turned DHCP off as I wanted IP Addresses to be assigned by the Dlink Router (it connects to the internet)

I then thought that connecting everything and logging into the DLink Router would tell me which IP Address has been assigned to the router. The TP Link OpenWRT router did not even appear in the list.

I then thought of doing a factory reset by holding the reset button down for about 30 seconds. Still nothing.

I have also tried to SSH into 192.168.42.129 (default gateway with phone) and 192.168.1.1. Still no luck. I know it is connecting to the router as elbit slow, i do get internet access from the desktop PC.

Did I semi-brick my router? Is there anything that can be done?

CURRENT IPCONFIG: Android phone plugged into TPLink USB Port
   Connection-specific DNS Suffix  . :
   IPv6 Address:                   2001:8004:1400:1695:c8b0:7f28:82e6:2a58
   Temporary IPv6 Address:         2001:8004:1400:1695:5dea:52e6:f234:72b3
   Link-local IPv6 Address :       fe80::c8b0:7f28:82e6:2a58%7
   IPv4 Address:                   192.168.42.51
   Subnet Mask:                    255.255.255.0
   Default Gateway :               fe80::1053:dcff:fe32:d6fd%7
                                   192.168.42.129

Have you installed Luci interface?

I dont think so but I was able to access the web interface before (thats how i set up the USB tethering and bridge)

In the process i ran the following commands from shell in the following order:

wget http://downloads.lede-project.org/releases/17.01.0/targets/ar71xx/generic/packages/Packages.gz
opkg update
opkg install kmod-usb-net kmod-usb-net-rndis kmod-usb-net-cdc-ether usbutils udev

Is it possible it was installed as part of those steps?

You can try to install Luci or reset the device.

opkg update
opkg install luci

I would love to but to do that I would need to connect to the router. I don't know what the routers IP address is and the standard factory reset (pressing reset button for a long time) isnt doing anything.

You disabled the DHCP, that's why you can't connect vto the router.
You can change your PC or Android phone's wifi to static IP, like 192.168.1.x

2 Likes

192.168.x.y
X must be equal as router's gateway. Y can be 0 to 254.
For instance your gateway is 192.168.42.129, then you may set the static IP as 192.168.42.2.
Now you can try to access Luci using openwrt.lan or the router's gateway

I have tried the following settings:

CONFIGURATION 1:
Static IP:       192.168.1.50
Default Gateway: 192.168.1.2

CONFIGURATION 2:
Static IP:       192.168.1.50
Default Gateway: 192.168.1.1

CONFIGURATION 3:
Static IP:       192.168.0.50
Default Gateway: 192.168.0.1

After each test I tried to ping the default gateway, if the request timed out i cancelled and moved onto the next configuration. None of these configurations worked.

As the DLink was operating on the 192.168.1.1 IP. I needed to set the Static IP Address before to 1.2.

Tested 1.1 and 0.1 as the settings could have been reverted during reset that did not quite work.

Isn't your router's gateway 192.168.42.129?

If it was then why cant i connect to it when i type the IP address into the browser? Only conclusion i can make is that 42.129 is the phone and not the router? I have however completed a ping of all ip addresses on the 42 subnet and only 51 (the pc) and 129 (the router/android phone?) returned any responses.

EDIT: I tried using the 42.129 as default gateway address anyway and was able to access the internet but still unable to connect to the OpenWRT web or ssh interface

You couldn't connect the router because you disabled DHCP.

I agree with you. However usually you can still connect via static addresses. I dont know why it is not working this time around.

Have you tried to set the gateway to 192.168.42.129 and static address to 192.168.42.2?
What's your router's gateway? Do you know it?

I have tried setting my PCs static ip to 192.168.42.50 and the gateway to 192.168.42.129 then tried to connect to the router by typing 192.168.42.129 into the browser and putty. This does not work. I thought the gateway of my router was one of the following:

  • 192.168.1.1
  • 192.168.1.2
  • 192.168.0.1
  • 192.168.42.129

none of these have worked. on each attempt I have made the IP address of my desktop PC .50 on the relevant subnet.

Default gateway is the machine that is a link to the Internet. For the usual home router LAN to WAN setup that IP also is your router.

You're not doing that though.

You're letting the phone do all the routing, so it is the default gateway. The OpenWrt box is serving as a media converter from wifi or Ethernet to USB. It is switching packets, not routing them. This is known as a dumb AP. There is only one network active in a dumb AP, the LAN.

The OpenWrt LAN network should have an IP address in the 192.168.42 range. It could be statically set or obtained from the phone by DHCP. This IP is only for logging in to administer. It is not a gateway route.

Overall this is probably not what you want to do. Your wired ISP is not being used at all.

1 Like

Ended up biting the bullet and doing a TFTP reset and then restoring it with OpenWRT. This worked fine and now I have an OpenWRT router back. Will attempt USB tethering again another time. Wondering if it is possible/desirable to have a USB tethered connection and use both a lan/wired internet connection together with the tethered connection for maximum speed. Will probably look into this another time.

A second line generally can’t get a home user more speed for each individual connection. This is because TCP/IP is address-based and each of the lines has a different IP address.

A second line can be used for fail-over or for sending some connections over one line and the rest over the other. The mwan3 package is one starting point.

See if the router is announcing its IPv6 address and try that, since you seem to have forgotten your router's IPv4 address.