Unable to access router

I flashed Openwrt on a TP-Link Archer A7 AC 1750 and all went well.

I accessed the router and started configuring it and it again all went well until I got to the wireless setting. I made a change (I can't remember what!) and now the router doesn't boot.

The power light stays on and is steady, but the two wireless lights and network connection lights keep flashing. I've tried resetting with the reset button a couple of times, but it made no difference.

I'd welcome some suggestions, please?


Tried wired connection?

It is a wired connection.

If you don't remember the change you made, the best option is to use failsafe mode to reset the router back to defaults and then start configuring again (hopefully paying a bit more attention to your changes this time).

Thanks. The first thing I saw with 'Failsafe Mode' is:
"Recommended for most users: Wait for a flashing LED and press a button"

What button? The only button on my router is the on/off.

I don't hold out much hope for this, as I can't even ping the router!

There is a reset button immediately to the right of the power button... you'll need a paperclip to press it. And there is also another button for wifi/wps on the far right of the back panel. This assumes this image is indeed of the Archer A7

It was the reset button I pressed (several times for over 10 seconds each time.

The image was this one:

It flashed OK and booted every time (until I fixed' it!).

When I engage failsafe mode, I often press the button repeatedly and rapidly.

Also, make sure you've set your computer to a static IP such as with a subnet mask of and that it is directly connected to the lan port on the C7. There should be no other network connections.

Once failsafe mode is running, you should get ping returns from, and then you can ssh into the router (root@ The web interface does not run in failsafe mode.

Thanks 'psherman'.

I must admit that I'm rather losing the will. I'm 84 ffs - I'm no longer a bright eyed whipper snapper, full of piss and vinegar!

I may come back to it later, but It's looking increasingly likely that the router will end up as a stand for my chocolate teapot!

The good news is that it won't melt the teapot since it will probably not even be powered on... but, I don't recommend chocolate and tea inside your electronics :wink:

In all seriousness, we can try to help you if you have the energy/time/desire to try to fix it... but we'll need to get specifics from you on what you've tried and what you're observing, and you'll need to follow instructions/suggestions carefully if you do want to revive the unit. Let us know what you want to do (or when).

If it's significant, the two radio/wireless Leds repeatedly flash 3 times, then a short delay, and so on.

I don't know what is expected to happen with the LED, but the more important thing is if the ethernet ports are functioning and the network is alive.

Are you able to get ping responses from the device when connected by ethernet with a static IP?

Thanks for staying with me 'psherman'!

An additional dimension to my problem is that I've got the router connected to a W10 machine (to avoid taking my Linux machine offline.

I loath W10 and only set it up for Photoshop. I've avoided any of the settings wherever possible, and my heart sinks at the prospect of having to tinker with the network settings. I may have to take my Linux machine offline to tackle your suggestion.

Assuming that I can SSH into the router, what commands/settings will I need to issue to enable me to get back to the GUI interface?

running firstboot should reset the settings.

1 Like

Thanks 'frollic'. I'll probably tackle it tomorrow.

These devices are rather resilient and hard to break unintentionally, so chances are pretty good to recover it easily.

First attempt.

  • let it fully boot up (don't touch it for ~5 minutes after powering up)
  • press the reset button with a paper clip for just over 10s
  • wait another ~5 minutes
  • try to connect (browser and ssh)

Second attempt, the failsafe/ firstboot approach linked above.

Third attempt, push-button tftp recovery, the same approach you had to do for the initial OpenWrt installation from the OEM firmware.

According to your description of events, either of these should work, in ascending order of getting more invasive.
...and the third approach should recover basically anything that could be recovered by 'normal' means.

Not sure what you mean by this. I made the initial installation through the TP-Link web gui.

I don't own the device in question (but some of its rather similar predecessors) and was under the impression that push-button tftp recovery via the bootloader was the only options for the initial installation.

Either way, if your description of the events is correct, you don't need (and shouldn't) go that far, the plain factory reset should get this sorted.

Nope - it's beyond my capabilities/patience. So 'chocolate teapot stand' it is!

I must say that I'm disappointed that a simple user mis-configuration in a gui, can cause an OpenWrt router to fall over.

Many thanks for the advice I received from the forum.

It can't, this can always be recovered (by definition) with a plain factory reset (keeping the reset button pressed for over 5s or using firstboot). That doesn't mean you couldn't kill (any-) router, but that kind of requires active intent of force-flashing to the wrong mtd (this may be fatal for all practical intents and purposes) or flashing a broken/ wrong/ oversized image.

By definition (especially on this kind of hardware), OpenWrt consists of a read-only (immutable) firmware part (the squashfs) and the writable overlay, all configuration (and addon package installations) only go into this overlay - resetting deletes/ reformats this overlay, so you're back to firstboot conditions.