Unable to access Google Analytics after install of OpenWRT 18.06.4 on TP-Link Archer C7 v2

Hi all,

Just as the title says. Error returned is:


I thought it was my ad-block package, but that's been disabled and I am still getting the error.

Only was able to access once after a router reboot, but it stops after some time again.

@stillmatic, welcome to the community!

  • You're describing the behavior of suspending Adblock - are you sure you disabled Adblock, or merely suspended it?
  • Have you tried adding the domain to the whitelist?
  • You do realize that this domain generates metadata for ad presentation (among other things)? It's blocked on my setup currently (and DNS_PROBE_FINISHED_NXDOMAIN is the exact error given when blocked):
::: results for domain 'analytics.google.com'
  + analytics.google.com
::: results for domain 'google.com'
  + adservice.google.com.au
  + www.google.com-document-view.alibabatradegroup.com
  + ads.google.com
  + adservice.google.com
  + adservices.google.com
  + adwords.google.com
  + analytics.google.com
  + id.google.com
  + googleadapis.l.google.com
  + pagead.l.google.com
  + [...]
  • Did you test if Adblock is blocking it - by querying the domain in the app?

I thought I did disable it, but I guess you're right.

I'm using adblock basic, so it doesn't seem that I get many options to configure it in Luci as you are showing on yours...

I am attempting to whitelist the url, but am still facing the same issue.

And likewise, I don't see yours.

Honestly, I would think you're trying to whitelist the domain, not "domain URL." If you read the instruction under domain URL, it states that's used to download a list. The instructions under Whitelisted domains clearly states:

Individual domains to be whitelisted

I would add it there.

For more detailed information, ask it's creator, @dibdot; and/or see the Adblock support thread.

Hope this helps.

Ahhh, that worked! Thanks so much @lleachii!

1 Like

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.