UK Plusnet FTTC config for Aug 2021

Hi Everyone,
I hope you are well.
I am trying to figure this out because I see some contradicting information.

https://www.plus.net/help/broadband/broadband-connection-settings/
The above says to use PPPoE

Broadband username or login name 	yourusername
@plusdsl.net
Connection type or encapsulation 	PPPoE Always On
Password 	The password you use to log in to the Member Centre
VLAN 	Active
VLAN ID (802.1q) 	101
VLAN ID (802.1p) 	0

but this does not work.
I log in to my old Plusnet Hub router and I cannot extract any more information about the actual configuration, all is preprogrammed and hidden but when it establishes the connection it says "PPP"
not "PPPoE".

When I login to my Plusnet account it says PPP as well.
https://www.plus.net/member-centre/broadband/connection-details/

Always-on Broadband xDSL

Dial-up access (BT Line) N/A
Dial-up access (non-BT Line) 0845 xxxx
Login name xxxxx@plusdsl.net
Password ********
Authentication Method CHAP
Server type PPP
IP Address Server assigned
Model	BT Home Hub 5A
Architecture	xRX200 rev 1.2
Firmware Version	OpenWrt 19.07.8 r11364-ef56c85848 / LuCI openwrt-19.07 branch git-21.189.23240-7b931da
Kernel Version	4.14.241

When I use PPP configuration in OpenWRT the connection is showing as UP but from the log I see there is an issue and modem is going in circles:

DSL Status
Line State:UP [0x0]
Line Mode:G.993.2 (VDSL2)
Line Uptime:20m 31s
Annex:B
Profile:17a
Data Rate:27.432 Mb/s / 14.967 Mb/s
Max. Attainable Data Rate (ATTNDR):28.859 Mb/s / 15.675 Mb/s
Latency:0.13 ms / 0.0 ms
Line Attenuation (LATN):16.3 dB / 19.8 dB
Signal Attenuation (SATN):16.9 dB / 19.8 dB
Noise Margin (SNR):4.4 dB / 4.6 dB
Aggregate Transmit Power (ACTATP):5.4 dB / 13.3 dB
Forward Error Correction Seconds (FECS):0 / 0
Errored seconds (ES):8 / 2516
Severely Errored Seconds (SES):0 / 490
Loss of Signal Seconds (LOSS):0 / 1
Unavailable Seconds (UAS):58 / 58
Header Error Code Errors (HEC):0 / 0
Non Pre-emptive CRC errors (CRC_P):0 / 0
Pre-emptive CRC errors (CRCP_P):0 / 0
ATU-C System Vendor ID:Broadcom 193.144
Power Management Mode:L0 - Synchronized
Sun Aug 29 16:53:48 2021 daemon.notice pppd[18121]: Connect: ppp-wan <--> /dev/ttyLTQ0
Sun Aug 29 16:53:48 2021 daemon.notice pppd[18121]: Modem hangup
Sun Aug 29 16:53:48 2021 daemon.notice pppd[18121]: Connection terminated.
Sun Aug 29 16:53:49 2021 daemon.info pppd[18121]: Exit.
Sun Aug 29 16:53:49 2021 daemon.notice netifd: Interface 'wan' is now down
Sun Aug 29 16:53:49 2021 daemon.notice netifd: Interface 'wan' is setting up now
Sun Aug 29 16:53:49 2021 daemon.notice pppd[18245]: pppd 2.4.7 started by root, uid 0
Sun Aug 29 16:53:49 2021 kern.info kernel: [ 1469.235977] ppp-wan: renamed from ppp0
Sun Aug 29 16:53:49 2021 daemon.info pppd[18245]: Renamed interface ppp0 to ppp-wan
Sun Aug 29 16:53:49 2021 daemon.info pppd[18245]: Using interface ppp-wan
Sun Aug 29 16:53:49 2021 daemon.notice pppd[18245]: Connect: ppp-wan <--> /dev/ttyLTQ0
Sun Aug 29 16:53:49 2021 daemon.notice pppd[18245]: Modem hangup
Sun Aug 29 16:53:49 2021 daemon.notice pppd[18245]: Connection terminated.
Sun Aug 29 16:53:50 2021 daemon.info pppd[18245]: Exit.
Sun Aug 29 16:53:51 2021 daemon.notice netifd: Interface 'wan' is now down
Sun Aug 29 16:53:51 2021 daemon.notice netifd: Interface 'wan' is setting up now
Sun Aug 29 16:53:51 2021 daemon.notice pppd[18378]: pppd 2.4.7 started by root, uid 0
Sun Aug 29 16:53:51 2021 kern.info kernel: [ 1471.271260] ppp-wan: renamed from ppp0
Sun Aug 29 16:53:51 2021 daemon.info pppd[18378]: Renamed interface ppp0 to ppp-wan
Sun Aug 29 16:53:51 2021 daemon.info pppd[18378]: Using interface ppp-wan
Sun Aug 29 16:53:51 2021 daemon.notice pppd[18378]: Connect: ppp-wan <--> /dev/ttyLTQ0
Sun Aug 29 16:53:51 2021 daemon.notice pppd[18378]: Modem hangup
Sun Aug 29 16:53:51 2021 daemon.notice pppd[18378]: Connection terminated.

In interfaces the WAN is showing as DOWN and the error is:
Unknown error (NEGOTIATION_FAILED)

Please not this is RJ11 plug that comes from a filtered BT socket. I don't have any DSL modems in front of OpenWrt router.

Please advise.
Best regards

Have you studied the Installation guide for HH5A?
https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=266

If your HH5a is wired to RJ11 phone/DSL wall socket, see sections 7.5 and 9.1 of the guide.

Did you configure the vlan 101 (ie. dsl0.101) ?

Other reference:
https://openwrt.org/docs/guide-user/network/wan/isp-configurations#vdsl4

1 Like

Running for the last 10 days. Replace vlan 35 with 101 below.
My network setup:

root@HH5A:~# uci show network
network.loopback=interface
network.loopback.device='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd01:2345:6789::/48'
network.atm=atm-bridge
network.atm.vpi='0' ; Bell Canada
network.atm.vci='35' ; Bell Canada
network.atm.encaps='llc'
network.atm.payload='bridged'
network.atm.nameprefix='dsl0.35'
network.dsl=dsl
network.dsl.annex='a'
network.dsl.tone='av'
network.dsl.ds_snr_offset='0'
network.@device[0]=device
network.@device[0].name='br-lan'
network.@device[0].type='bridge'
network.@device[0].ports='eth0.1'
network.@device[1]=device
network.@device[1].name='eth0.1'
network.@device[1].macaddr='12:34:56:78:9a:bc'
network.lan=interface
network.lan.device='br-lan'
network.lan.proto='static'
network.lan.ipaddr='192.168.5.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.@device[2]=device
network.@device[2].name='dsl0.35'
network.@device[2].macaddr='12:34:56:78:9a:bd'
network.wan=interface
network.wan.proto='pppoe'
network.wan.username='username'
network.wan.password='password'
network.wan.ipv6='auto'
network.wan.device='dsl0.35'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 1 2 4 6t'
network.@switch_vlan[0].vid='1'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='5 6t'
network.@switch_vlan[1].vid='2'
network.@switch_vlan[2]=switch_vlan
network.@switch_vlan[2].device='switch0'
network.@switch_vlan[2].vlan='3'
network.@switch_vlan[2].ports='5t 6t'
network.@switch_vlan[2].vid='35'
root@HH5A:~#

I have followed the guide but then it says: Network device is not present.
I think PPPoE is not good for this setup. Strange

Can you post the contents of the /etc/config/network file. (remove your plusnet username & pw).

(If you are a Windows user, you can use WinSCP to open the file - see section 10 of the guide)

I note you have posted image of ATM Bridge settings, which suggests you may not have totally followed the guide, although presence of those settings does not normally cause problems when using PPPoE. Can I suggest you factory reset the HH5a (see section 8 of the guide) and start from beginning and follow section 9.1 instructions for PPPoE without skipping any steps?

Definitely works with Plusnet FTTC/VDSL connection. Your DSL status image shows hub has sync with the FTTC green cab.

OpenWrt 19.07.8 only just came out a few weeks ago. No reason to suggest there is a problem with PPPoE though in this release.

1 Like

Are ATM Bridge settings applicable to VDSL?
It says in the guide "This is only for ADSL connection"
I just skipped it but took a screenshot anyway.

root@xxx:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbb:473b:26a6::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option ds_snr_offset '0'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'
	option annex 'b'
	option tone 'a'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr '84:a4:23:06:4f:fa'

config interface 'wan'
	option ifname 'dsl0.101'
	option proto 'pppoe'
	option password 'xxx'
	option ipv6 'auto'
	option username 'xxx@plusdsl.net'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '84:a4:23:06:4f:fb'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 6t'

How does it look to you?

Ok, so just for a test I went and I configured ATM settings according to what ISP says on their website:
VPI: 0
VCI: 38
Multiplexing method: VC Based or VC-Mux

which is different to default configuration 1, 32 and LLC
and as soon as I did that and restarted the interface, it's UP.

The Internet is ON the only issue is that I only get 50% of the down speed. So it looks like ADSL works but not VDSL2.


Sun Aug 29 20:33:03 2021 daemon.warn pppd[2456]: IPV6CP: timeout sending Config-Requests
Sun Aug 29 20:34:11 2021 daemon.err uhttpd[1229]: luci: failed login on /admin/network/network for root from 192.168.1.104
Sun Aug 29 20:34:21 2021 daemon.err uhttpd[1229]: luci: accepted login on /admin/network/network for root from 192.168.1.104
Sun Aug 29 20:39:30 2021 daemon.info hostapd: wlan1: STA 2c:d0:66:xx:xx:xx IEEE 802.11: authenticated
Sun Aug 29 20:39:30 2021 daemon.info hostapd: wlan1: STA 2c:d0:66:xx:xx:xx IEEE 802.11: associated (aid 1)
Sun Aug 29 20:39:30 2021 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 2c:d0:66:xx:xx:xx
Sun Aug 29 20:39:30 2021 daemon.info hostapd: wlan1: STA 2c:d0:66:e2:0e:81 WPA: pairwise key handshake completed (RSN)
Sun Aug 29 20:39:30 2021 daemon.info dnsmasq-dhcp[1872]: DHCPREQUEST(br-lan) 192.168.1.177 2c:d0:66:e2:0e:81
Sun Aug 29 20:39:30 2021 daemon.info dnsmasq-dhcp[1872]: DHCPACK(br-lan) 192.168.1.177 2c:d0:66:e2:0e:81
Sun Aug 29 20:39:50 2021 kern.warn kernel: [  560.030101] br-lan: received packet on eth0.1 with own address as source address (addr:84:a4:23:06:4f:fa, vlan:0)
Sun Aug 29 20:39:50 2021 kern.warn kernel: [  560.039060] br-lan: received packet on eth0.1 with own address as source address (addr:84:a4:23:xx:xx:xx, vlan:0)
Sun Aug 29 20:40:07 2021 daemon.info pppd[2456]: Terminating on signal 15
Sun Aug 29 20:40:07 2021 daemon.info pppd[2456]: Connect time 7.6 minutes.
Sun Aug 29 20:40:07 2021 daemon.info pppd[2456]: Sent 59271289 bytes, received 12788608 bytes.
Sun Aug 29 20:40:07 2021 daemon.notice netifd: Network device 'pppoe-wan' link is down
Sun Aug 29 20:40:07 2021 daemon.notice pppd[2456]: Connection terminated.
Sun Aug 29 20:40:07 2021 daemon.info pppd[2456]: Sent PADT
Sun Aug 29 20:40:07 2021 daemon.info pppd[2456]: Exit.
Sun Aug 29 20:40:07 2021 daemon.notice netifd: Interface 'wan' is now down
Sun Aug 29 20:40:07 2021 daemon.notice netifd: Interface 'wan' is disabled
Sun Aug 29 20:40:07 2021 daemon.notice netifd: Interface 'wan' is enabled
Sun Aug 29 20:40:07 2021 daemon.notice netifd: Interface 'wan' is setting up now
Sun Aug 29 20:40:07 2021 daemon.warn dnsmasq[1872]: no servers found in /tmp/resolv.conf.auto, will retry
Sun Aug 29 20:40:07 2021 daemon.err insmod: module is already loaded - slhc
Sun Aug 29 20:40:07 2021 daemon.err insmod: module is already loaded - ppp_generic
Sun Aug 29 20:40:07 2021 daemon.err insmod: module is already loaded - pppox
Sun Aug 29 20:40:08 2021 daemon.err insmod: module is already loaded - pppoe
Sun Aug 29 20:40:08 2021 daemon.info pppd[3175]: Plugin rp-pppoe.so loaded.
Sun Aug 29 20:40:08 2021 daemon.info pppd[3175]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sun Aug 29 20:40:08 2021 daemon.notice pppd[3175]: pppd 2.4.7 started by root, uid 0
Sun Aug 29 20:40:08 2021 daemon.info pppd[3175]: PPP session is 910
Sun Aug 29 20:40:08 2021 daemon.warn pppd[3175]: Connected to 20:e0:xx:d8:xx:xx via interface dsl0.101
Sun Aug 29 20:40:08 2021 kern.info kernel: [  577.841243] pppoe-wan: renamed from ppp0
Sun Aug 29 20:40:08 2021 daemon.info pppd[3175]: Renamed interface ppp0 to pppoe-wan
Sun Aug 29 20:40:08 2021 daemon.info pppd[3175]: Using interface pppoe-wan
Sun Aug 29 20:40:08 2021 daemon.notice pppd[3175]: Connect: pppoe-wan <--> dsl0.101
Sun Aug 29 20:40:08 2021 daemon.info pppd[3175]: CHAP authentication succeeded: CHAP authentication success
Sun Aug 29 20:40:08 2021 daemon.notice pppd[3175]: CHAP authentication succeeded
Sun Aug 29 20:40:08 2021 daemon.notice pppd[3175]: peer from calling number 20:E0:9C:xx:xx:xx authorized
Sun Aug 29 20:40:08 2021 daemon.notice pppd[3175]: local  IP address xxxx
Sun Aug 29 20:40:08 2021 daemon.notice pppd[3175]: remote IP address xxxx
Sun Aug 29 20:40:08 2021 daemon.notice pppd[3175]: primary   DNS address 213.120.234.42
Sun Aug 29 20:40:08 2021 daemon.notice pppd[3175]: secondary DNS address 213.120.234.38
Sun Aug 29 20:40:08 2021 daemon.notice netifd: Network device 'pppoe-wan' link is up
Sun Aug 29 20:40:08 2021 daemon.notice netifd: Interface 'wan' is now up
Sun Aug 29 20:40:08 2021 daemon.info dnsmasq[1872]: reading /tmp/resolv.conf.auto
Sun Aug 29 20:40:08 2021 daemon.info dnsmasq[1872]: using local addresses only for domain test
Sun Aug 29 20:40:08 2021 daemon.info dnsmasq[1872]: using local addresses only for domain onion
Sun Aug 29 20:40:08 2021 daemon.info dnsmasq[1872]: using local addresses only for domain localhost
Sun Aug 29 20:40:08 2021 daemon.info dnsmasq[1872]: using local addresses only for domain local
Sun Aug 29 20:40:08 2021 daemon.info dnsmasq[1872]: using local addresses only for domain invalid
Sun Aug 29 20:40:08 2021 daemon.info dnsmasq[1872]: using local addresses only for domain bind
Sun Aug 29 20:40:08 2021 daemon.info dnsmasq[1872]: using local addresses only for domain lan
Sun Aug 29 20:40:08 2021 daemon.info dnsmasq[1872]: using nameserver 213.120.234.42#53
Sun Aug 29 20:40:08 2021 daemon.info dnsmasq[1872]: using nameserver 213.120.234.38#53
Sun Aug 29 20:40:09 2021 user.notice firewall: Reloading firewall due to ifup of wan (pppoe-wan)

From your first post, these are VDSL speeds for FTTC superfast fibre, although the download speed of 27 Mb/s looks 'poor' relative to your upload speed imho.

What is currently reported in DSL stats?
ADSL maxes out around 22 Mb/s with max upload speed of around 1.0 Mb/s for Openreach ADSL regular broadband.

Follow the instructions in the guide for VDSL connections:

ie. Delete the ATM Bridge and see if it resolves the problem

1 Like

Ok, I deleted the ATM Bridge but before and after that change (I restarted the PPPoE interface) the speed reported in Overview is 27Mbit/s which is less than half what I usually get around 76Mbit/s.

**Line State:**UP [0x0]
**Line Mode:**G.993.2 (VDSL2)
**Line Uptime:**26m 59s
**Annex:**B
**Profile:**17a
**Data Rate:**27.524 Mb/s / 14.436 Mb/s
**Max. Attainable Data Rate (ATTNDR):**29.583 Mb/s / 15.217 Mb/s
**Latency:**0.13 ms / 0.0 ms
**Line Attenuation (LATN):**16.3 dB / 19.7 dB
**Signal Attenuation (SATN):**16.7 dB / 19.6 dB
**Noise Margin (SNR):**4.1 dB / 5.9 dB
**Aggregate Transmit Power (ACTATP):**4.8 dB / 13.1 dB
**Forward Error Correction Seconds (FECS):**0 / 0
**Errored seconds (ES):**0 / 2530
**Severely Errored Seconds (SES):**0 / 490
**Loss of Signal Seconds (LOSS):**0 / 1
**Unavailable Seconds (UAS):**59 / 59
**Header Error Code Errors (HEC):**0 / 0
**Non Pre-emptive CRC errors (CRC_P):**0 / 0
**Pre-emptive CRC errors (CRCP_P):**0 / 0
**ATU-C System Vendor ID:**Broadcom 193.144
**Power Management Mode:**L0 - Synchronized

Could it be that I just have to wait for ISP to renegotiate the link speed?
Upload speed is way over 1Mbit/s ADSL as you said pretty close to what I normally get 18Mbit/s.

**Data Rate:**27.524 Mb/s / 14.436 Mb/s
**Max. Attainable Data Rate (ATTNDR):**29.583 Mb/s / 15.217 Mb/s
**Line Attenuation (LATN):**16.3 dB / 19.7 dB
**Signal Attenuation (SATN):**16.7 dB / 19.6 dB
**Noise Margin (SNR):**4.1 dB / 5.9 dB

I agree your download speed of 27 mb/s seems poor.

Were you previously using regular Plusnet Hub One in same phone socket?

If you plug old router back in, does download speed return to 76 mb/s ?

What type of BT master socket do you have?

Have you ever tried router plugged into the hidden Engineer's Test socket behind the master socket?

Do you know age and history of the HH5A running OpenWrt? It may be faulty.... Some black hubs date back to 2013.....

1 Like

Ok, so in terms of the BT OpenReach socket it's MK2.

I have existing Plusnet Hub with their firmware side by side with the one that has OperWrt on it.
To me this OpenWrt one looks like brand new and the sticker is identical with the Plusnet Hub one, it actually says Sagecom CS 50001, the older Plusnet Hub I still have (had some weird issue Plusnet was not able to resolve so they gave me a new one) does not have Sagecom on that sticker (that place is blank).

Ok, let me check what speed do I get on the old router.
I have not plugged it to the inside socket.

Ok, it looks like the speed is the same which indicates a problem at the ISP side.
It could be I was downgraded and not even noticed it for several days.
I think we are good in terms of OpenWrt, am I right?

OpenWrt is like heaven in comparison to earth - original firmware.

Yes, openwrt config is ok.

There may be a genuine line fault which will require an engineer, or Openreach DLM accidentally kicked in thinking there was a fault, if you had repeatedly restarted the hub too many times.

You could try try the hidden engineer's test socket behind the lower half of your Mk2 filtered face plate, to rule out defective filtered face plate?

ok, great,
Yes it could be me disconnecting/connecting too many times
or a result of their overnight maintenances. I have noticed there was quite many over the recent weeks.
I think there was also an engineer doing something in the cabinet a week ago.

I test the socket tomorrow.
Thank you for your help.

I checked the inside socket but no improvement, the filter is ok.

Called up the ISP, it turns out there is a problem and engineer has been booked.
I reckon they did something at the cabinet when I briefly got disconnected a week ago.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.