Uci : Entry not found

Executing 'uci get wireless.radio0.disabled' and 'uci get network.wan.disabled' returns 'uci : Entry not found' error. Bellow are the outputs for 'uci show network' and 'uci show wireless'


These are the files in the directory /etc/config,

Any help to fix this will be highly appreciated.
Thanks,
George

https://openwrt.org/docs/guide-user/network/wifi/basic

3 Likes

I am still finding it hard to understand why my network uci configuration file does not have 'disabled' option in the 'wan' section.
This link(https://openwrt.org/docs/guide-user/network/ucicheatsheet) shows that this option should be there.

I don't know whether i have accidentally deleted this option. In case if that's what happened, is there any way i can revert this delete?

Please let me know if i am missing something here.
Thanks.

'uci get wireless.radio0.disabled' seems to be working now, but 'uci get network.wan.disabled' is still not working.

what do you mean by "it's not working"?

I have mentioned about that in my above comments. Please do let me know if it still doesn't make sense to you.

I didn't see a "disabled" option in your wan section ... therefore uci can't find such option/value. Please post the output of uci show network.wan - thanks.

1 Like

Here it is
image

then again, where is the problem?

1 Like

Shouldn't there be one more option called 'network.wan.disabled = '0''?

"disabled" is a not required option in this section and the default (when not set) is "0" aka "enabled". If you insist to set this option type:

# to enable this interface (the default, even without having explicitly set the option)
uci set network.wan.disabled=0
or 
# to disable this interface
uci set network.wan.disabled=1 

and finally uci commit network to save your changes

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.