Ubnt EdgeRouter X Firmware v1.10.10 can not install OpenWrt

Hello all,

I have 2 Unifi EdgeRouter X here on which I want to install OpenWrt.
On one it worked right away, on the other I've been trying for ages.

The router that doesn't work is using firmware v1.10.10.
When I try to install firmware 2 via tftp, the router is unreachable.
I have updated the bootloader to version "e50_002_4c817".

Openwrt installation works until sysupgrade:

root@OpenWrt:~# sysupgrade -n /tmp/openwrt-19.07.7-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.bin
Commencing upgrade. Closing all shell sessions.
Connection to closed by remote host.
Connection to closed.

After that the router reboots and is not reachable anymore. My computer is not assigned an IP, the port is connected and disconnected in a loop for about 3 seconds.
Also the port LEDs blink irregularly - regardless which port is busy.
Additionally all LEDs are blinking with low brightness every few seconds.

What is the reason for this and what am I doing wrong?
Both routers were purchased at the same time. Could it be a different production batch?
Or is it really because only firmware v1 can be installed on one and v2 on the other?
Is there any way to upgrade the firmware branch?

Thanks a lot

1 Like

Don't plug a non-POE device into port 4-- it may cause a short circuit if the port output power GPIO is turned on in the firmware. There is no hardware protection against this. (also if you plug a professional 802.3af device into the port with the power on, the device may be damaged. It is only for Ubiquiti "passive" 24 volt PoE.)

If the bootloader is TFTP recovery capable you can flash either recovery image from Ubiquiti. These are the only images that can be flashed by TFTP recovery.

TFTP recovery is started by powering on with the reset button pressed and holding it pressed for 30 seconds or more until the port LEDs start flashing in a "wig-wag" pattern. This is strictly a bootloader feature, the firmware never boots.

1 Like

Unfortunately, the answer does not help me.

I can only flash the image v1 via tftp.
If I flash v2, the router is no longer accessible.

Hello...I was able to flash the OpenWrt factory binary using the EdgeOS firmware upgrade option.
Factory tar link: https://downloads.opennet-initiative.de/ubnt/edgeos/openwrt-ramips-mt7621-ubnt-erx-initramfs-factory.tar

When I did it, the firmware on this site was an old out of date OpenWrt version, but it passed the EdgeOS firmware signature check and was good enough to let me sysupgrade to OpenWrt version.

Then install OpenWrt version 18.06 first with sysupgrade from the command prompt.
The correct 18.06 version is:

Then after successful installation put any version you like.

Please tell me if it works for you.

If the ER-X is like the ER-10X, I loaded the Image into RAM via tftp for testing. Once you are happy no issues, just flash the sysupgrade thru Luci or cli to write it to the device.

Do you install it??

Hello, sorry for the late reply.
Unfortunately it does not work either. Same problem as before.

Your flash of the factory binary via the EdgeOS works. I then copy the new openwrt version via SCP to the factory openwrt and install it with sysupgrade.
After that the same problem, that the router is stuck in the boot loop.

The ports connect and disconnect and my computer recognizes every second a connected port and again not.

Can this be a hardware error that OpenWrt is not flashable?

Are you sure you have done the flash correctly??

What could be wrong with the flash?

I have two ER-X routers, with both I did the same with the flash. The first one worked, this one was stuck in the boot loop afterwards.

Maybe the second has different boot loader?

Yes, I have already updated the boot loader.

Flashed v1, updated the bootloader and then flashed openwrt. But same problem.