Ubiquity AP AC Pro no 5Ghz on many clients

So I just got a brand-new Ubiquiti UniFi AC Pro to replace my old crap TP-Link 802.11agn router. Install was completely painless. Just set it up as a very basic AP with DHCP client on the LAN port. The problem is a bunch of my 5GHz-capable devices fail to even see the SSID on 5Ghz, it's like it's not on, but several other clients have zero issues. I've tried every possible permutation of channel and spacing/bandwidth (20/40/80), AC mode, N mode, legacy mode, WPA2 & 3, 802.11w enabled & disabled, I'm all out of ideas!

The deets:
OpwnWrt 21.02.2 r16495-bf0c965af0
Qualcomm Atheros QCA956X ver 1 rev 0

The following devices connect just fine:

Intel 8260 iwlwifi driver
Samsung A12 (android)

The following devices fail to see the SSID:

Intel 6205 iwlwifi driver
Realtek RTL8814AU rtl88XXau driver

The realtek device is advertised specifically as an 802.11ac device, and was purchased within the last 6 monts.

You'll also notice two devices using the iwlwifi driver, the older of which fails, and the newer of which works, so I guess it's not a driver issue. Both are on laptops running the latest Mint 20.03.

So, I'm all out of ideas. The 2.4G is really congested in my location, so I'd really like to get the 5G working on all my devices, they all worked flawlessly with the TP-link router.


Try using channel 36?

Oh, that was nasty. Some helpful references:

So it would seem Luci uses the lowest 20MHz channel as the number, because 36 & 100 both seem to work @ 40 & 80MHz. 36 is hopelessly congested in most populated areas, I don't recommend it.

Problem #2, no permutation of WPA3 settings would allow connect on all my systems. However WPA2 is just fine.

WPA3 needs to be supported on the clients as well.

1 Like

Make sure your correct country code is set on both radios. With the country unset, you get reduced wifi performance because it can only use the restricted frequencies and modes that would be legal anywhere.

Sage words my friend, glad you could add to the conversation along side AashishAS.

I would add that all the warring systems are current linux distros. And the main hangup appears to be some need 802.11w to be set to "required" and others to "disabled". As it mentions right below the setting, some drivers & hardware choke on 802.11w hard (not sure why some won't connect without it though, but who am I). So, in other words, WPA3 isn't really mature, I recommend anyone who reads this post just go with WPA2 only and move on with their lives, which is why I brought it up in the first place.

If reality follows the second link I posted, channels 52 & 116 are also solid choices, although I haven't gotten a chance to try them as 100 appears to fit my needs. I can confirm that 149 which appears to be a valid choice from the table did not, in fact, work.

Or, you could find out what devices you have that support WPA3, and set up a separate guest/IoT WiFi network for those only.

In most geographic locations, 52 and 116 are DFS (radar) channels, and should be avoided.

Select a channel in the range 36 to 48, or 149 to 161.

1 Like

Could they make the next 802.11 standard bloody channel hop already? The level of esoteria is getting obscene lol

149 is the sweet spot, not congested and widely available. Try setting your driver country to India, this can help make channel 149 work for testing purposes.