Ubiquiti Edgerouter X | Telmex

Hello,

I'm from Mexico and I have two EdgeRouter X (ER-X), that I was able to install OpenWrt to them, so far so good in dhcp mode.

I want to use them at work and home and our current ISP is TELMEX, I want to avoid using double NAT. So on home I have a Fiber ONT and at work they use ADSL2+ modem on copper. Telmex uses on ADSL/optic fiber. Also it seems uses TR069 and I was able to put their white modem into bridge mode (layer 2). They use PPPoE accounts preregistered into those modems.

I was able to get a PPPoE user account and password for home and for the account at work. So in theory their modem in mode bridge (L2) pass the internet over their Lan 1 and I use that to connect to my WAN.

For ADSL2+

it seems these are the information for Telmex

PPPoE connection
Encapsulation: RFC 2516 PPPoE
Multiplexing: LLC
Autodetect: Disable
QoS: UBR
Virtual Circuit: 8 VPI - 81 VCI
DSL Modulation: Multimode.

I was able to connect with another old cisco router but didn't ask at all these information.

on CISCO I used these information

Network
Wan Connection WAN1
PPPoE
username: pppoe_user
password: pppoe_password
service name: empty
Keep alive: Redial Period: 15 sec
MTU: 1492

Network: (required by some ISPs)
Host name: ipsdl-mex-nettengo-119 / 
Domain name: emtpy

After 5 minutes, the cisco router is able to connect with the ISP

Things I believe I need to get is VLAN it seems for fiber and adsl VLAN 881, but not sure what I'm doing wrong.

I'm attaching my network file

So I want to be able to get internet (wan) on Eth0 and use the other LAN2-5 for distribution.

network file for Edge Router to connect to ISP with PPPoE

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd9f:eccc:b663::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'eth2'
	list ports 'eth3'
	list ports 'eth4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.7.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.881'
	option hostname 'prodigy.net.mx'
	option proto 'pppoe'
	option ipv6 '0'
	option username 'user@domain'
	option password 'pppoepassword'

so if anyone from MX or have experience with ISP with PPPoE with vlans, let me know. I have been watching some tutorials that uses OpenWrt but nothing so far. Thank you

I'm not well versed with DSA, but your device is now DSA on 21.02. So... I think you want do this a bit differently.

config bridge-vlan
	option device 'br-wan'
	option vlan '881'
	list ports 'eth0:t'

config interface 'wan'
	option device 'br-wan.881'
	option hostname 'prodigy.net.mx'
	option proto 'pppoe'
	option ipv6 '0'
	option username 'user@domain'
	option password 'pppoepassword'

See this for more info

thank you. I'll try this today at home and on the week at work and I'll report back with my discoveries. I'll check the DSA thing too.

If you did not need to configure a VLAN on the Cisco router, you wouldn't need it on OpenWrt either. Modems and ONTs in bridge mode often still do transformations like adding / removing VLAN tags so the Ethernet port is untagged while on the media to the ISP it is tagged, this tagging being performed inside the modem as configured.

Anyway with DSA the syntax for tagged packets on the wan link would be option device 'wan.881' and for untagged it is just option device 'wan' It is not necessary to create a br-wan or bridge-vlans or '8021q' devices, just add the number to the default configuration that sends packets directly to the wan port.

3 Likes

Thanks. My bad on that earlier suggestion (I don’t have any dsa devices to work with, but I was looking at the linked tutorial).

1 Like

indeed, but I have read to other users in MX that they require to replicate the VLAN 881 for their WAN connection. So far I wasn't been able to repeat with success on the OpenWrt and I think I was lucky with the CISCO, I'll do the changes and I'll report back.

So for the DSA should I leave my configuration

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd9f:eccc:b663::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'eth2'
	list ports 'eth3'
	list ports 'eth4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.7.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

## suggested changes
config interface 'wan.881'
	option device 'wan'
	option hostname 'prodigy.net.mx'
	option proto 'pppoe'
	option ipv6 '0'
	option username 'user@domain'
	option password 'pppoepassword'

No sure where to add the number to the default configuration. I'm still learning.

This simplification does only work for something like a wan port where the VLAN does not need to be hardware switched to another port.

The name of the interface needs to remain 'wan' for the firewall to work properly. The tag is applied by changing the option device within wan.

config interface 'wan'
    option device 'wan.881'
...

But again if you didn't need to tag a VLAN with the CIsco router that did connect, don't do it here either.

Reading the System Log is often very useful to diagnose a pppoe failure to connect. The two largest problems are "Timeout waiting for PADO packets" which means there is no link at all (wrong VLAN?) and having the ISP reject your MAC address, which usually makes them send some sort of failure to authenticate message from their end, which you can see in the log.

1 Like

Is okay :slight_smile: I'm still learning and trying any options! I have a few weeks breaking my head just trying to this thing to work. So far I'm impressed with the openwrt OS

OK wait a minute I think on the Edgerouter-X the DSA ports are actually named 'eth0' 'eth1' etc as is marked on the case. Which is really confusing since every other MT7621 calls them 'wan' 'lan1' 'lan2' etc. It has been a while since I used my Edgerouter-X.

okay, I'll wait. I'm still confusing what should put on the network file.

config interface 'wan'
	option device 'eth0.881'
	option hostname 'prodigy.net.mx'
	option proto 'pppoe'
	option ipv6 '0'
	option username 'user@domain'
	option password 'pppoepassword'

It is probably either the above (if you need tagging) or the below if you don’t.

config interface 'wan'
	option device 'eth0'
	option hostname 'prodigy.net.mx'
	option proto 'pppoe'
	option ipv6 '0'
	option username 'user@domain'
	option password 'pppoepassword'
2 Likes

thank you. I'll try and report back!

When the cisco router worked, did it receive the same (public) IP-address as your original router?

I don't remember, I will check it this week at the office and I'll let you know.

update: success with the first configuration at home. It seems it needs tagging. Yay! I'll update on the week for the office configuration. But at home I finally made the connection.

update: success with the first configuration at home. It seems it needs tagging. I've connection finally :smiley:

I'll update on the week for the office configuration.That's where is the ADSL2 instead fiber and there we have the CISCO. So I'll update on the week.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.