U-Boot hangs @ "Uncompressing Kernel Image ..."


some time ago I got a EasyBox 802 (Arcadyan ARV752DPW) that wasn't needed by anyone anymore.
So now I decided to take some time and try to put OpenWrt onto it.
I want to use it as a Mips Developement Board - it would be okay for me if Wifi won't work as long as ethernet works.

I followed the instructions from https://openwrt.org/toh/arcadyan/arv752dpw in order to install U-Boot.
I then flashed https://downloads.openwrt.org/releases/18.06.1/targets/lantiq/xway/openwrt-18.06.1-lantiq-xway-arcadyan_arv752dpw-initramfs-kernel.bin to the, as far as I know, correct address in memory - which should be 0xB0040000.

After power-up, it stops @ "Uncompressing Kernel Image ..."
At firtst I thought that this may be caused by a broken flash chip.
I wrote a 7mb file to flash, dumped it and compared checksums. Everything was fine --> Flash is working.
Same for memory (Tested with the Memtest utility of the standard bootloader).
I also tried using older and/or self compiled images but I got the same result every time.
Since the EasyBox 802 was NOT working (Flash was erased) when I got it, I can't test if it works with default firmware from Vodafone.

Here it what I received via serial connection on startup:

ROM VER: 1.0.3
CFG 01

U-Boot 2013.10-openwrt4 (Jun 25 2018 - 08:59:44) ARV752DPW

Board: Arcadyan ARV752DPW
SoC:   Lantiq Danube-S v1.3
CPU:   333.333 MHz
IO:    166.667 MHz
BUS:   83.333 MHz
DRAM:  64 MiB
Flash: 8 MiB
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   rtl8306_probe: chipid 5988, chipver 0, chiptype 3
rtl8306_setup: CPU link up: 1
Hit any key to stop autoboot:  0 
## Booting kernel from Legacy Image at b0040000 ...
   Image Name:   MIPS OpenWrt Linux-4.9.120
   Created:      2018-08-16   7:51:15 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    3087426 Bytes = 2.9 MiB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ...

Hopefully somebody can give me a hint on how to get this working.


  1. there are a few notes in that guide about it not working.... not sure if that is just for no serial method.

  2. Notes seem to indicate version: 15.05.1 was the one they were built around..... ( get a hold of legacy / known good source? )

  3. A long shot but ... Most things will give you an error ( at the loading kernel stage )...... one that may not is when the image stomps on some memory that's used for something already..... you can try changing the memory address ( in variable or command only ( non destructive )) that the kernel gets copied to WHEN ITS LOADED!!! ...... my gut tells me it's not gonna help..... worth a try when similar symtoms accur tho' in a general sense.

I notice the guide ( perhaps to be safe ) uses a spare address of 0x80500000 as a free area...... but that's for a smaller file......

Thanks for the reply. Actually, your guess is kind of right.
I used a 'wrong' (it was the image provided by OpenWRT) U-Boot image which was too big.
That caused the kernel to be loaded into memory which was used by the bootloader, so it overwrote the loaded
bootloader while loading the kernel ==> The device got stuck.

The problem is solved by using a older and smaller U-Boot image OR by changing the load address of the kernel. (I have not tested the second option)

I noticed some people complaining about wifi not working with the Easybox802 - everything works fine for me with OpenWrt 18.06.1 r7258-5eb055306f.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.