Two IPv6 Subnets on single bridge mode using Route48

Hello,
I am trying to get two IPv6 subnets on two Lan Interfaces while using the OpenWrt router on bridge mode.

So far, IPv4 Works fine, But IPv6 doesn't seem to work. Lan1 is in the IPv6 relay mode, and Lan2 is in DHCP mode. On Lan2, IPv6 is obtained and it works, but on Lan1 the Ipv6 is obtained, but the route stays empty, because of which ping doesn't work. After about 5 mins, the route gets filled in and the ping starts working. Not sure why its taking so much time. While connecting a phone on wifi(bridged to lan), the IPv6 is never obtained.

I even have a static route setup for ipv6.

I did some digging using radvdump, and it looks like IPv6 breaks after another radvd config is received.

[1st]

[2nd] IPv6 breaks when this is received.

I am not sure why router is advertising this, if its required to be advertised, why is it breaking the working connection.

I would pull a config backup, then reset the config and then start over with a minimal setup of only WAN plus LAN plus ipv6 plus relay. nothing else.
You then still have the initial config backup as reference.

Then gradually add things on after the other until you hit any error. Then iteratively solve the issue, before you proceed adding further configs.

Currently you have too much parts configured and dont know, which part is causing the issues.

I understand. I did start again from scratch and figured out Google Nest hub is the culprit. It seems to be sending RA because of which the routes get lost.

Is there a way to filter these out? or probably disable on nest hub?

I was able to resolve this by blocking specific mac address RA on the firewall.

For anyone looking at How to do it on Luci?


Thanks for the help. @Pico

someone recently had a similar problem with AppleTV.

AppleTVs newer generations have an IoT hub service default-on. („IoT hub“, „Thread“ protocol and brand new „Matter“ protocol are relevant keywords). Nest could have some similar hub service default on. To simplify local IoT networks for non-IT-gifted users, they have this and it comes with some IPv6-RA.

I would check the Nest GUI, maybe there is a menu, to „disable IoT hub“, „disable thread“, „disable matter“ or something like that.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.