Turning off Radar Detection on DFS channels?

Hi all. I live in a block of flats.
My DL-Link DIR 842 router with OpenWRT operates on channel 124 in HT80 AC mode. In the recent weeks my router started do drop the 5 GHz radio sporadically. There is no any radar working at my location or nearby, probably some weird interference coming from my neighbours and OpenWRT deceting it as radar signal, and shuts the radio down.
Channels from 36 to 64 and 100 to 112 are over-crowded due my neighbours, 149-161 can be good option, but some of my devices doesent recognize these channels. So I can use 120-136 channels only with no interference. So how I can turn off radar detection of DFS channels? It is possible?

if you could disable it, why implement the DFS function in the 1st place ?


I know what are you saying, but my case is special.
My router doing this sporadically drop on 128, 132, 136 channles too..

No, you aren't special. The law applies to you as it does for everyone else.

The only option would be to use a channel that doesn't need DFS (often ch36-48) - DFS channels may only be used for indoor operations, provided your router vacates the frequencies immediately in the presence of an active radar (and radar operators tend to have means to enforce these regulations, by force, if necessary).


-and depending on the nation (or instance) the military controls radio. I don't think you desire to cause an issue they have to seek out. In any case, don't play with circumventing DFS. Additionally, it's against the forum rules to try [to ask] to violate any law.

You can feel free to set non DFS channels if you don't want a DFS cut off.


Okay, I understand. An other solution is possible? When my router detects signal on 124, jump to 136, or vice-versa. It can be a good and legal option. Again: I live in a "polluted" area, channels from 36 to 64 are almost useless because lot of AP's there.

Not a licensed attorney...and I don't think [it's wise that] anyone [here via the forum] should be offering you legal advice (i.e. this is all done in upstream software - near the Linux Kernel).

But, technically:

Have you tried adding the channels in a list?

This can be done via command line - e.g.:

#in /etc/config/wireless 
# in wifi-device config

option channels '124 136'

I hope now that you better understand why.

Also, welcome to the community!


I understand this should be option channels per this post: Turning off Radar Detection on DFS channels? - #18 by hnyman


Yes, I understand. But now why my device drops completely 5GHz radio instead of setting channel to 36..48 or 149...161 instead?

PS: if my post is against the rules, delete it!
The rules of 5 GHz in my country (Hungary) not very clear as in the US and in the UK.

Are you saying that you tried the setting already?

You dont have to follow any rule - simply set:

#in /etc/config/wireless 
# in wifi-device config

        option country 'HU'

You don't have to worry about understanding any rules.

# HU as part of EU/CEPT accepted decisions 2005/513/EC (5GHz RLAN, EN 301 893)
# and 2006/771/EC (amended by 2008/432/EC, Short-Range Devices, EN 300 440)
#  EU decision 2005/513/EC: https://eur-lex.europa.eu/legal-content/EN/TXT/?uri=CELEX:02005D0513-20070213
#  EU decision 2006/771/EC: https://eur-lex.europa.eu/legal-content/EN/TXT/?uri=CELEX:02008D0432-20080611
#  EU decision 2021/1067/EC: https://eur-lex.europa.eu/legal-content/EN/TXT/PDF/?uri=CELEX:32021D1067&from=EN
# Harmonized CEPT countries (July 2019): https://www.ecodocdb.dk/download/25c41779-cd6e/Rec7003e.pdf
# HU: http://stir.nmhh.hu/?oldal=dokumentumGeneralo&root_rendeletelem_id=3&hatalyos=1
# HU: http://english.nmhh.hu/cikk/297/Eljarasi_tajekoztato_a_24_GHzes_es_az_5_GHzes_savban_mukodo_berendezesek_engedelyezeserol
# HU: http://nmhh.hu/dokumentum/319/kis_hatotavolsagu_eszkozok_srdk.pdf
country HU: DFS-ETSI
	(2400 - 2483.5 @ 40), (100 mW)
	(5150 - 5250 @ 80), (200 mW), NO-OUTDOOR, AUTO-BW, wmmrule=ETSI
	(5250 - 5350 @ 80), (100 mW), NO-OUTDOOR, DFS, AUTO-BW, wmmrule=ETSI
	(5470 - 5725 @ 160), (500 mW), DFS, wmmrule=ETSI
	# short range devices (ETSI EN 300 440-1)
	(5725 - 5875 @ 80), (25 mW)
	# 6 GHz band
	(5945 - 6425 @ 160), (23), NO-OUTDOOR, wmmrule=ETSI
	# 60 GHz band channels 1-4 (ETSI EN 302 567)
	(57000 - 66000 @ 2160), (40)

what about enabling 802.11r between the 5GHz and 2.4GHz wifis ?
in the best of worlds, the clients should be able to roam between those two, without losing the
connectivity, when the DFS kicks in.

problem is, you can't really automagically force them back on to the 5GHz wifi once the AC radio
comes back up.


Here is the log:

Wed Jul 19 06:59:12 2023 daemon.notice hostapd: wlan0: DFS-RADAR-DETECTED freq=5620 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5610 cf2=0
Wed Jul 19 06:59:12 2023 daemon.notice hostapd: dfs_downgrade_bandwidth: no DFS channels left, waiting for NOP to finish
Wed Jul 19 06:59:12 2023 daemon.notice hostapd: wlan0: AP-DISABLED
Wed Jul 19 06:59:12 2023 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0

It turned the radio off, instead of set to another channel.

What is your wireless configuration?

cat /etc/config/wireless

Let's see the config. Please obscure passwords.

Here is my config:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option distance '2000'
        option cell_density '3'
        option htmode 'VHT80'
        option country 'HU'
        option channel '124'
        option txpower '20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key '***'
        option ieee80211w '2'
        option encryption 'psk2+ccmp'
        option ssid 'MYSSID_5G'
        option ieee80211r '1'
        option mobility_domain 'B0EE'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option distance '2000'
        option noscan '1'
        option cell_density '3'
        option htmode 'HT40'
        option channel '3'
        option country 'HU'
        option txpower '20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option key '***'
        option ssid 'MYSSID_2.4G'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option mobility_domain 'B0EE'


I found 40Mhz channels more robust in busy environments. Maintain better connectivity at cost of reduced bandwidth.

Channels 165-173 are also legally available in most countries (up to you to verify your use case) - some routers can do 165 at 20Mhz.

Most modern client devices can connect to ch 165. Try and see or upgrade if you think it is worth it: A single 20Mhz channel only gives you ~100Mbps throughput (link speed of 433Mbps on 802.11ac 5Ghz).

You could also go the other route on 2.4Ghz and see if channels 12, 13, 14 are legal there and if your equipment works on those channels.

If you stay on non DFS channels then another solution would be to buy more AP's and locate them throughout the flat. I know some users may argue this but you can run them at half power or less to get better zone coverage / less hidden nodes.

Hey it ain’t that hard. You are in EU, Bryssel decides everything in your life.

So look at Europe rules under 5GHz ac:

1 Like

I bought a 10'X1' coil of aluminum sheet for about $10, for Wifi shielding from the neighbors. I park my AP up against it. My AP also works well when parked in the kitchen between the metal laundry boxes and the kitchen stove.

1 Like

There is one alternative option (albeit not everywhere yet), turning over to 6 GHz, no DFS requirements, less interference from neighbours. In very congested environments, 6 GHz can make a real difference.

The list of alternative fallback channels to try is actually a separate option "channels".
See 5 GHz WLAN craps out (upon radar detection?) - start_dfs_cac() failed - #12 by Borromini for example and discussion


So that the average Joe does not start using DFS channels next to a weather station, but knowledgeable users can still use it when they are nowhere near one, like OP probably is and the vast majority of people as well?

This mechanism is pretty much useless and many times, as OP has found out, poorly implemented. Do you think that a 25mW EIRP signal from a WiFi home device will reach weather stations and military bases miles away? It can bearly cover a 50 feet radius area. And most people don't live near one anyway.

The law has a clear 'opinion' on this, nor can you know that there's no radar installation within range (hint, there are mobile ones operated by the military). Likewise the effect of rogue APs on weather radars has already been demonstrated over dozens (pl.) of kilometres.