Trying to install OpenVPN using the Basic Guide - Errors


Just loaded LuCI openwrt-18.06 branch (git-19.170.32094-4d6d8bc)/ OpenWrt 18.06.4 r7808-ef686b7292 on a WRT3200ACM.

Using this Basic Guide OpenVPN basic

When I get to step 3. Basic server and try to execute these lines:

I get the following errors:

I did try to enter then exactly as written, but I end up with

I have to hit Cntrl-D to exit out of it.

I checked and /etc/easy-rsa/pki/issued is there. As well as vpnserver.crt
I've also tried executing the command using /bin/grep.

Haven't been able to find anything searching around on the forums regarding this type of error as well. Been on DD-WRT for a number of years and ventured into the OpenWRT world since getting this new router - which I love so far!


Note that the lines block continues until the "done" about 30 lines downward. That is one command until that... It does not end at "do".

You might copy that whole code block into a script and run it as a script.

Yup. That worked. Thanks so much! After you pointed that out, I had a "Duh!" moment :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.