Trunk vlan on switchport on router

I have a working trunk on switch port 5.61 on my mt-6000
How do i get that vlan 61 on my router port number 4 as a accessport (untagged)

/b

Let’s take a look at the config - this way we can see exactly what is there and recommend the relevant changes.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network

So i´d like same vlans on lan4
and say for example vlan 55 on lan3
is that doable?

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxxxxxxxxxxxxxxxx::/48'
        option packet_steering '2'
        option steering_flows '128'

config device
        option name 'br-lan'
        option type 'bridge'
        option ipv6 '0'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'
        option hostname '*'

config device
        option type '8021q'
        option ifname 'lan5'
        option vid '55'
        option name 'lan5.55'
        option ipv6 '0'

config interface 'lan55'
        option proto 'static'
        option device 'lan5.55'
        option ipaddr '192.168.55.1'
        option netmask '255.255.255.0'
        option delegate '0'

config device
        option type '8021q'
        option ifname 'lan5'
        option vid '56'
        option name 'lan5.56'
        option ipv6 '0'

config device
        option type '8021q'
        option ifname 'lan5'
        option vid '60'
        option name 'lan5.60'
        option ipv6 '0'

config device
        option type '8021q'
        option ifname 'lan5'
        option vid '70'
        option name 'lan5.70'
        option ipv6 '0'

config interface 'user56'
        option proto 'static'
        option device 'lan5.56'
        option ipaddr '192.168.56.1'
        option netmask '255.255.255.0'
        option delegate '0'

config interface 'dmz'
        option proto 'static'
        option device 'lan5.60'
        option ipaddr '192.168.60.1'
        option netmask '255.255.255.0'
        option delegate '0'

config interface 'mgmt70'
        option proto 'static'
        option device 'lan5.70'
        option ipaddr '192.168.70.1'
        option netmask '255.255.255.0'
        option delegate '0'

config device
        option type '8021q'
        option ifname 'lan5'
        option vid '101'
        option name 'lan5.101'
        option ipv6 '0'

config interface 'ext101'
        option proto 'static'
        option device 'lan5.101'
        option ipaddr '192.168.101.1'
        option netmask '255.255.255.0'

config interface 'wg1'
        option proto 'wireguard'
        option private_key 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
        option listen_port '55555'
        option delegate '0'
        list dns '192.168.55.1'
        list addresses '10.0.100.1/24'

config wireguard_wg1
        option description 'xxxx-s24'
        option public_key 'xxxxxxxxxxxxxxxxx'
        option private_key 'xxxxxxxxxxxxxxxxxxxxx'
        option preshared_key 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
        list allowed_ips '10.0.100.2/32'
        option route_allowed_ips '1'

config device
        option name 'eth0'
        option ipv6 '0'

config device
        option name 'eth1'
        option ipv6 '0'

config device
        option name 'lan1'
        option ipv6 '0'

config device
        option name 'lan3'
        option ipv6 '0'

config device
        option name 'lan4'
        option ipv6 '0'

config device
        option name 'lan5'
        option ipv6 '0'

config device
        option name 'wg1'
        option ipv6 '0'

config device
        option name 'phy0-ap0'
        option ipv6 '0'

config device
        option name 'lan5.61'
        option type '8021q'
        option ifname 'lan5'
        option vid '61'
        option ipv6 '0'

config device
        option name 'lan2'
        option ipv6 '0'

config interface 'IOT_61'
        option proto 'static'
        option device 'lan5.61'
        option ipaddr '192.168.61.1'
        option netmask '255.255.255.0'
        option delegate '0'

config device
        option type 'bridge'
        option name 'br_trunk1'
        option bridge_empty '1'
        option ipv6 '0'
        list ports 'lan1'
        list ports 'lan5.55'

config bridge-vlan
        option device 'br_trunk1'
        option vlan '55'
        list ports 'lan1'
        list ports 'lan5.55:t'

 {
        "kernel": "6.6.86",
        "hostname": "mt6000",
        "system": "ARMv8 Processor rev 4",
        "model": "GL.iNet GL-MT6000",
        "board_name": "glinet,gl-mt6000",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.1",
                "revision": "r28597-0425664679",
                "target": "mediatek/filogic",
                "description": "OpenWrt 24.10.1 r28597-0425664679",
                "builddate": "1744562312"
        }
}

You need to use bridge-VLANs (i.e. DSA syntax). It'll probably be easiest if you reset to defaults and start with a fresh config. Then, follow this tutorial:

https://openwrt.org/docs/guide-user/network/dsa/dsa-mini-tutorial

If you still need help, please post your default config and I can help you with the appropriate edits.

Hehe well thank you, but the whole idea of me posting how i get another trunk on my lan4 with my existing configuration without starting over with the other apps i have installed

it was easy(er) with the old switch if recall correctly

You need to make some fairly significant changes to the network config file as it will not work the way you've got it now.

How many additional packages did you install?

One trick you can use is attended sysupgrade -- that can generate an image for you, and then you can "upgrade" without keeping settings... this will reset the device to defaults again while maintaining all your packages. If you create a backup before this, you'll have all your config files and you can simply upload those again.

Another approach you can take would be to:

  • make a backup
  • issue the following commands:
mv /etc/config/network ~/network.bak
cp /rom/etc/config/network /etc/config/network
  • Restart.

This will reset your network config to the default, and from there we can setup the bridge VLANs properly.