Troubleshooting DHCP & DNS with VLAN setup (multiple dnsmasq instances for different interfaces)

Hi, this is a follow-up to a previous question I posted here. I've gotten VPN split tunneling partially working after adjusting the config in the managed switch per the answer in the last question, but am unable to get an IP assigned through DHCP when doing so and have to use an upstream DNS server instead of pointing to the router.

This is my current config for the router:

#
# /etc/config/dhcp
#
config dnsmasq
	list notinterface 'vlan'
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option localservice '1'
	option ednspacket_max '1232'
	option confdir '/tmp/dnsmasq.d'
	option cachesize '10000'
	option strictorder '1'
	option quietdhcp '1'
	option port '54'
	list server '127.0.0.1'
	list server '::1'
	option noresolv '1'

config dnsmasq 'vlan'
 	list interface 'vlan'
 	list notinterface 'loopback'
 	option domainneeded '1'
 	option localise_queries '1'
 	option rebind_protection '1'
 	option rebind_localhost '1'
 	option local '/local/'
 	option domain 'local'
 	option expandhosts '1'
 	option authoritative '1'
 	option readethers '1'
 	option leasefile '/tmp/dhcp-vlan.leases'
 	option localservice '1'
 	option ednspacket_max '1232'
 	option confdir '/tmp/dnsmasq-vlan.d'
 	option cachesize '10000'
 	option strictorder '1'
 	option quietdhcp '1'
 	option port '53'
 	list server '127.0.0.1'
 	list server '::1'
 	option noresolv '1'
 	option nonwildcard '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option force '1'
	list dhcp_option '6,192.168.99.1'
	option ra_default '1'

config dhcp 'vlan'
	option interface 'vlan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option force '1'
	list dhcp_option '6,1.1.1.1' # Would prefer to point to router.

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	option start '100'
	option limit '150'
	option leasetime '12h'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

#
# /etc/config/network
#

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'dd4b:559d:cf82::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.99.1'
	option ip6assign '64'
	option ip6hint 'AA'
	option ip6class 'local'

config interface 'wan'
	option device 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.254'
	option ipaddr '192.168.1.100'
	list dns '9.9.9.9'
	list dns '149.112.112.112'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'
	option peerdns '0'
	list dns '2620:fe::fe'
	list dns '2620:fe::9'

config interface 'wg'
	option proto 'wireguard'
	option private_key 'KEY'
	list addresses 'ADDRESSES'
	option force_link '1'

config wireguard_wg
	option description 'wg'
	option public_key 'KEY
	option endpoint_port '51820'
	list allowed_ips '0.0.0.0/0'
	list allowed_ips '::/0'
	option endpoint_host 'HOST'
	option route_allowed_ips '1'

config route6
	option target '::/0'
	option interface 'wg'

config interface 'vlan'
	option proto 'static'
	option ipaddr '192.168.100.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'eth0.100'
	list ip6class 'wan6'

This switch config is unchanged.

Here's a connection test after manually assigning my computer an IP:

$ ping openwrt.org
PING openwrt.org (139.59.209.225): 56 data bytes
64 bytes from 139.59.209.225: icmp_seq=0 ttl=49 time=211.634 ms
64 bytes from 139.59.209.225: icmp_seq=1 ttl=49 time=189.953 ms
^C
--- openwrt.org ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 189.953/200.793/211.634/10.841 ms
$ nslookup openwrt.org
Server:		1.1.1.1
Address:	1.1.1.1#53

Non-authoritative answer:
Name:	openwrt.org
Address: 139.59.209.225
Name:	openwrt.org
Address: 2a03:b0c0:3:d0::1af1:1
$ nslookup openwrt.org 192.168.100.1
;; communications error to 192.168.100.1#53: connection refused
;; communications error to 192.168.100.1#53: connection refused
;; communications error to 192.168.100.1#53: connection refused
;; no servers could be reached

And here's what my computer's network panel looks like when plugged into port 4 on the switch, using DHCP and then a manual connection: