Troubleshooting cfi-flash/mtd/jffs2/opkg problem with 18.06.1/development (works with 17.01.6)

I have a Buffalo WZR-HP-G300NH (ar71xx) and I have no issues with Lede 17.01.6 (kernel 4.4) and dd-wrt.
I installed both 18.06.1 (kernel 4.9) and development snapshot and I get jffs2 errors when installing packages.
I tried also to write to /dev/mtdblock5 (/overlay jffs2) from failsafe with filesystem not mounted and I get errors, only with 18.06.1/development. I have no errors flashing from tftp.

I already opened a topic in "Installing and Using OpernWrt" and written what I have already done so far
Impossible to install/update any packages on WZR-HP-G300NH 18.06.1

Maybe flash is getting old and it's taking too much time to reply OS requests, and newer kernel version could have shorter timing or different logic.
Router is old so I haven't found other user that could replicate the problem.

Could you help me to troubleshoot this problem ?

thank you

Just to confirm the problem reported by fabio. I have three WZR-HP-G300NH two with A0 D0 tags and one with A0 F08 tag, and on the one with the last tag I have problems installing packages (I don't think this matters, but the one with
A0 F08 tag has the newer switch). By doing many reboots inbetween I have
been able to ultimately install the desired packages but just one or two
packages at a time. After each commandline reboot there were jffs2 messages
in dmesg for nodes with CRC errors most of which disappeared with time, but
one stills recurs with each reboot.
If this were due to a partally broken flash, is there a way to analyze the flash?
BTW, df -k shows only 17% use on /dev/mtdblock5

I have just tried to install the latest snapshot on the above system
and I still have the same problems. Reverting to 17.01.6 works
without problems.

Yes, same to me, with 18.06.1, ar71xx build from trunk, and ath79 build from @musashino repo.

I don't know how to continue with troubleshooting, but available to test patched builds.

Openwrt 18.06.0 is not having this cfi-flash/mtd/jffs2/opkg problem.