- What happens when you click the Remove button to remove the default SSID and start from scratch?
- Which uci commands are printed in this change when you click on unsaved changes?
Here, you do not say you have reset your device completely to defaults. Are you positive you are starting with defaults? This can be done by holding in the reset button or not keeping settings after an install. Try the reset button? And then stay out of the /etc/config/* files and let LuCI configure a basic set-up.
Like odrt, I strongly suspect this is a configuration issue. Maybe you keep making an unintended change somewhere again and again in vi, or introduce it again and again by copying in a config file with the problem still in it? I've been there and done that myself before and it is no fun
I suppose it is possible you have a bad hardware device, but that would be the very last thing I would suspect.
you probably need to revert to ofw for warranty so maybe try it anyway to see if it's the issue reproduces
I would reset to defaults in this case and start from scratch. How to do a factory reset:
I would do this with 23.05-RC4.
I just saw something that may solve the problem
please read this thread
Thread - network unreachable 23-05-rc4
Here is what is happening
These are the uci commands
uci del wireless.wifinet1
uci set wireless.wifinet1=wifi-iface
uci set wireless.wifinet1.device='radio0'
uci set wireless.wifinet1.mode='ap'
uci set wireless.wifinet1.ssid='OpenWrt'
uci set wireless.wifinet1.encryption='psk2'
uci set wireless.wifinet1.key='xxxxxxxx'
I tested with multiple scenarios:
- Doing the configuration on a newly flashed device
- Performing the flash followed by a
rm /etc/config/wireless && reboot
You can also see from my previous screenshot that I am testing with an almost new device where I did not even set the root password.
When I flashed I converted it to UBI and I did not do any backup. I've been using OpenWrt for a very long time and I never had such issues, so I was ok with not having the ability to revert back to stock. If you have backup files, it would be interesting to check if with stock firmware the 2G is working or note (regardless of the warranty).
I did the following commands
firstboot && reboot
opkg update
opkg install luci luci-ssl
Soon after rebooting the situation is like this.
I did it with OpenWrt SNAPSHOT r24054-fe10f97439
. As per your suggestion I flashed 23.05-rc4 and made sure not to keep the settings and performed the same steps. Result is the same: 2G is not working.
On RC4, after a fresh boot and enabling the two networks, the /etc/config/wireless looks like this.
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/18000000.wmac'
option channel '1'
option band '2g'
option htmode 'HT20'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
config wifi-device 'radio1'
option type 'mac80211'
option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option channel '36'
option band '5g'
option htmode 'HE80'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
It is a bit different than the previous one, so I run these commands
mv /etc/config/wireless /etc/config/wireless.bak
wifi config
wifi reload
After enabling from luci, the file looks like this
config wifi-device 'radio0'
option type 'mac80211'
option phy 'wl0'
option channel '1'
option band '2g'
option htmode 'HT20'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
config wifi-device 'radio1'
option type 'mac80211'
option phy 'wl1'
option channel '36'
option band '5g'
option htmode 'HE80'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
Of course the 2G is still not working.
This looks like a completely different configuration compared to mine, I just want to use the router in ap mode, I am not sure how this relates.
Have a quick look at the post linked below about missing firmware, check and see if this is what is the cause of your issue also…
https://forum.openwrt.org/t/openwrt-23-05-0-rc4-fourth-release-candidate/173307/27
This could be the reason.
@Boydon how did you install 23.05-RC4, via auc attended sysupgrade or via the regular sysupgrade image from https://downloads.openwrt.org/releases/23.05.0-rc4/targets/ ?
If auc does not include the mt7622 firmware then this could explain the behavior.
I think we can exclude this hypothesis. Reasons:
- The OP has not used attended sysupgrade and the loss of firmware is a bug only applicable to building custom images or attended sysupgrades with the literal preservation of package lists;
- The OP tried a known-working stable version already
Apparently all is in the right place
root@OpenWrt:~# opkg install kmod-mt7622-firmware kmod-mt7915-firmware
Package kmod-mt7622-firmware (5.15.132+2023-08-14-b14c2351-1) installed in root is up to date.
Package kmod-mt7915-firmware (5.15.132+2023-08-14-b14c2351-1) installed in root is up to date.
I am old style user, I never use auc. I always download sysupgrade images and flash them.
My /etc/config/wireless for the mt7622 radio looks like this:
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/18000000.wmac'
option band '2g'
option htmode 'HT20'
option country 'DE'
option cell_density '0'
option channel '1'
config wifi-iface 'wifinet2'
option device 'radio0'
option mode 'ap'
option ssid 'my2gssid'
option encryption 'psk2+ccmp'
option key 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
option network 'lan'
The difference may be that you configured a complete open SSID with no encryption at all, while my configuration is set to WPA2-PSK CCMP.
And my configuration of wifi-device radio0 points to a path (/sys/devices/platform/18000000.wmac), while yours adresses a phy interface.