Trouble with extroot in OpenWrt 22.03.5

I recently upgraded to OpenWrt 22.03.5, had to do a fresh install and tried configuring extroot. It seems I have messed up with setting up fstab, since when I run block info, I see only the following:

/dev/mtdblock5: UUID="052e869a-5e925913-fd01a3bc-856ad302" VERSION="4.0" TYPE="squashfs"
/dev/sda1: UUID="28854925-6e5f-4ec0-b728-b07915960d83" VERSION="1.0" TYPE="ext4"

While it was listed before I started the operation, now /dev/mtdblock6 is no longer present. /dev/sda1 is the memory stick I had used as extroot storage.

I tried to go for a reset from the web interface, but after selecting "Perform select" and a few seconds I just get returned to the home page. How deep trouble am I in and how can I recover from this situation?

Is everything working? What is the ouput of

df -h
1 Like

The router seems fully functioning at this moment, other than being able to factory reset it via LuCI.


proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,nosuid,noexec,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,noatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
none on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,noatime,mode=700)

df -h

Filesystem                Size      Used Available Use% Mounted on
tmpfs                    60.6M      1.1M     59.5M   2% /tmp
overlayfs:/overlay        2.7M      2.2M    512.0K  81% /
tmpfs                   512.0K         0    512.0K   0% /dev

By the way, the router I have is an Asus RT-N56U A1.

I have no problem doing a factory reset or flashing the firmware again, I'm just concerned if doing either of these actions will make things worse with the current state of my router.

I did both a soft factory reset and a hard factory reset, both seemed to go perfectly fine. However, the other mtdblock device is still missing when I run block info:

root@OpenWrt:/# block info
/dev/mtdblock5: UUID="052e869a-5e925913-fd01a3bc-856ad302" VERSION="4.0" MOUNT="/rom" TYPE="squashfs"

Still, the mtdblock6 device is present in /proc/mounts:

root@OpenWrt:/# cat proc/mounts
/dev/root /rom squashfs ro,relatime 0 0
proc /proc proc rw,nosuid,nodev,noexec,noatime 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,noatime 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev,noatime 0 0
tmpfs /tmp/root tmpfs rw,noatime,mode=755 0 0
tmpfs /dev tmpfs rw,nosuid,noexec,noatime,size=512k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,noatime,mode=600,ptmxmode=000 0 0
debugfs /sys/kernel/debug debugfs rw,noatime 0 0
none /sys/fs/bpf bpf rw,nosuid,nodev,noexec,noatime,mode=700 0 0
/dev/mtdblock6 /overlay jffs2 rw,noatime 0 0
overlayfs:/overlay / overlay rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work 0 0

Running block mount does not the mtdblock device to appear.

EDIT: I just noticed that even after performing the resets, the packages I installed before performing the resets were still installed, nor did I have to reassign the root password.

Hard factory reset

1 Like

Re-flashed my device, installed block-mount and block info now lists both mtdblock devices :+1:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.