Trouble with AriaNg

i've installed aria2 and it works fine from CLI. However, i wanted to add a user interface so i tried
ariang-nginx and webui-aria2. Unfortunatly, The both didnt work.

Aria2 Settings

aria2.main=aria2                                                                                                                                      
aria2.main.bt_enable_lpd='true'                                                                                                                       
aria2.main.enable_dht='true'                                                                                                                          
aria2.main.follow_torrent='true'                                                                                                                      
aria2.main.save_session_interval='30'                                                                                                                 
aria2.main.header=''                                                                                                                                  
aria2.main.enabled='1'                                                                                                                                
aria2.main.rpc_auth_method='none'                                                                                                                     
aria2.main.max_concurrent_downloads='1'                                                                                                               
aria2.main.max_connection_per_server='16'                                                                                                             
aria2.main.min_split_size='1M'                                                                                                                        
aria2.main.split='16'                                                                                                                                 
aria2.main.extra_settings='check-certificate=false' 'enable-rpc=true' 'rpc-allow-origin-all=true' 'rpc-listen-all=true' 'rpc-listen-port=6800'        
aria2.main.disk_cache='5M'                                                                                                                            
aria2.main.file_allocation='prealloc'                                                                                                                 
aria2.main.dir='/mnt/sda1/usb/aria2'                                                                                                                  
aria2.main.config_dir='/mnt/sda1/usb/aria2'                                                                                                           
aria2.main.enable_logging='true'                                                                                                                      
aria2.main.log_level='debug'                                                                                                                          
aria2.main.user='aria2'    

here are the logs for aria2 (don't mind the "start" at the beginning of the log, it was echo'd in so i can tail)

root@OpenWrt:~# tail -f /var/log/aria2.log
start

2019-06-23 03:24:49.478989 [INFO] [Context.cc:179] <<--- --- --- ---
2019-06-23 03:24:49.479174 [INFO] [Context.cc:180]   --- --- --- ---
2019-06-23 03:24:49.479353 [INFO] [Context.cc:181]   --- --- --- --->>
2019-06-23 03:24:49.479725 [INFO] [Context.cc:182] aria2 1.34.0
2019-06-23 03:24:49.479923 [INFO] [Context.cc:183] gcc 7.4.0
  built by  x86_64-pc-linux-gnu
  targeting arm-openwrt-linux-gnu
  on        Jun 20 2019 12:18:25
2019-06-23 03:24:49.480100 [INFO] [Context.cc:184] Linux 4.19.52 #0 SMP Thu Jun 20 10:47:19 2019 armv7l
2019-06-23 03:24:49.480454 [INFO] [Context.cc:185] zlib/1.2.11 OpenSSL/1.1.1c
2019-06-23 03:24:49.480616 [INFO] [Context.cc:186] Logging started.
2019-06-23 03:24:49.480760 [DEBUG] [Context.cc:216] Not setting rlimit NO_FILE: 1024 >= 1024
2019-06-23 03:24:49.480931 [INFO] [SocketCore.cc:1653] Checking configured addresses
2019-06-23 03:24:49.482434 [INFO] [SocketCore.cc:1704] Not considered: 127.0.0.1
2019-06-23 03:24:49.482697 [INFO] [SocketCore.cc:1701] Found configured address: 192.168.1.1
2019-06-23 03:24:49.482860 [INFO] [SocketCore.cc:1701] Found configured address: 156.223.102.213
2019-06-23 03:24:49.483242 [INFO] [SocketCore.cc:1704] Not considered: ::1
2019-06-23 03:24:49.483483 [INFO] [SocketCore.cc:1704] Not considered: fe80::5aef:68ff:fe5d:1fe3%eth1
2019-06-23 03:24:49.483656 [INFO] [SocketCore.cc:1701] Found configured address: fd5c:5a88:41db::1
2019-06-23 03:24:49.484059 [INFO] [SocketCore.cc:1704] Not considered: fe80::5aef:68ff:fe5d:1fe2%br-lan
2019-06-23 03:24:49.484446 [INFO] [SocketCore.cc:1704] Not considered: fe80::58ef:68ff:fe5d:1fe6%wlan0
2019-06-23 03:24:49.484875 [INFO] [SocketCore.cc:1704] Not considered: fe80::5aef:68ff:fe5d:1fe4%wlan1
2019-06-23 03:24:49.485129 [INFO] [SocketCore.cc:1704] Not considered: fe80::8c30:afff:fe77:3d64%ifb4pppoe-wan
2019-06-23 03:24:49.485301 [INFO] [SocketCore.cc:1709] IPv4 configured=1, IPv6 configured=1
2019-06-23 03:24:49.488666 [WARN] [DownloadEngineFactory.cc:201] Neither --rpc-secret nor a combination of --rpc-user and --rpc-passwd is set. This is insecure. It is extremely recommended to specify --rpc-secret with the adequate secrecy or now deprecated --rpc-user and --rpc-passwd.
2019-06-23 03:24:49.489487 [INFO] [HttpListenCommand.cc:106] CUID#8 - Using port 6800 for accepting new connections
2019-06-23 03:24:49.490198 [NOTICE] [HttpListenCommand.cc:108] IPv4 RPC: listening on TCP port 6800
2019-06-23 03:24:49.490995 [INFO] [HttpListenCommand.cc:106] CUID#9 - Using port 6800 for accepting new connections
2019-06-23 03:24:49.491357 [NOTICE] [HttpListenCommand.cc:108] IPv6 RPC: listening on TCP port 6800
2019-06-23 03:25:02.674880 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54604.
2019-06-23 03:25:02.676960 [INFO] [HttpServerCommand.cc:275] CUID#10 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:365] errorCode=1 Bad HTTP header: missing ':'
2019-06-23 03:25:02.769803 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54605.
2019-06-23 03:25:02.772480 [INFO] [HttpServerCommand.cc:275] CUID#11 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:165] errorCode=1 Bad Request-Line: missing request-target
2019-06-23 03:25:03.761362 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54606.
2019-06-23 03:25:03.763185 [INFO] [HttpServerCommand.cc:275] CUID#12 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:165] errorCode=1 Bad Request-Line: missing request-target
2019-06-23 03:25:03.764508 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54607.
2019-06-23 03:25:03.765622 [INFO] [HttpServerCommand.cc:275] CUID#13 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:193] errorCode=1 Bad Request-Line: missing HTTP-version
2019-06-23 03:25:04.643433 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54608.
2019-06-23 03:25:04.644520 [INFO] [HttpServerCommand.cc:275] CUID#14 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:221] errorCode=1 Bad Request-Line: LWS after HTTP-version
2019-06-23 03:25:04.761744 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54609.
2019-06-23 03:25:04.763051 [INFO] [HttpServerCommand.cc:275] CUID#15 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:365] errorCode=1 Bad HTTP header: missing ':'
2019-06-23 03:25:05.689245 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54610.
2019-06-23 03:25:05.694334 [INFO] [HttpServerCommand.cc:275] CUID#16 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:193] errorCode=1 Bad Request-Line: missing HTTP-version
2019-06-23 03:25:05.758278 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54611.
2019-06-23 03:25:05.759245 [INFO] [HttpServerCommand.cc:275] CUID#17 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:193] errorCode=1 Bad Request-Line: missing HTTP-version
2019-06-23 03:25:06.719224 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54612.
2019-06-23 03:25:06.721088 [INFO] [HttpServerCommand.cc:275] CUID#18 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:193] errorCode=1 Bad Request-Line: missing HTTP-version
2019-06-23 03:25:06.751009 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54613.
2019-06-23 03:25:06.752280 [INFO] [HttpServerCommand.cc:275] CUID#19 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:193] errorCode=1 Bad Request-Line: missing HTTP-version
2019-06-23 03:25:07.645521 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54614.
2019-06-23 03:25:07.648540 [INFO] [HttpServerCommand.cc:275] CUID#20 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:321] errorCode=1 Bad HTTP header: missing LF
2019-06-23 03:25:07.756047 [INFO] [HttpListenCommand.cc:78] RPC: Accepted the connection from 192.168.1.5:54615.
2019-06-23 03:25:07.761303 [INFO] [HttpServerCommand.cc:275] CUID#21 - Error occurred while reading HTTP request
Exception: [HttpHeaderProcessor.cc:193] errorCode=1 Bad Request-Line: missing HTTP-version
2019-06-23 03:25:19.799144 [NOTICE] [SaveSessionCommand.cc:82] Serialized session to '/mnt/sda1/usb/aria2/aria2.session.main' successfully.

and the console log

Sun Jun 23 03:37:56 2019 daemon.info aria2: Aria2 will run with user 'aria2'.                                                                         
Sun Jun 23 03:37:56 2019 daemon.info aria2: Please make sure user 'aria2' has write access to download dir: /mnt/sda1/usb/aria2 

what i noticed was that in AriaNg (https://192.168.1.1/ariang) i'm unable to change any settings as if i'm not allowed.

Any Idea as to what's causing this or how to solve it?

1 Like

Exactly the same trouble here.

root@router:/dev# cat /etc/config/aria2 

config aria2 'main'
	option config_dir '/var/etc/aria2'
	option bt_enable_lpd 'true'
	option enable_dht 'true'
	option follow_torrent 'true'
	option file_allocation 'none'
	option save_session_interval '30'
	list header ''
	option dir '/mnt/data/download/aria2'
	option max_connection_per_server '4'
	option user 'aria2'
	option enable_logging 'true'
	option log_level 'debug'
	option rpc_auth_method 'none'
	option enabled '1'

I'm using the latest Davidc502 build OpenWrt SNAPSHOT r10307-629e6538a1 / LuCI Master (f138fc93), kernel 4.19.53. Aria2 version 1.34.0-6.

Thank you in advance for any idea on how to make it working.

i've made this script until this gets figured out.
https://github.com/syto203/Aria2c-Downloader

copy the "openwrt-only" script to your router and launch it by running " sh openwrt-only.sh"
default USB storage location is /mnt/sda1 and default download directory is /mnt/sda1/usb/video

Thank you for your effort to help. But I'm looking for a solution to make aria2c web clients working. Hopefully someone else will make use of your CLI downloader.

Hello
Install luci-app-uhttpd and uncheck "Redirect all HTTP to HTTPS" and go http://192.168.1.1/ariang
Another solution to use ariang in https: [solved] Aria2 : ssl/handshake failure : unable to get local issuer certificate with https links
To see if that's the problem.

1 Like

@sunarowicz Aria2 is already CLI the script was meant as a front end to automate some stuff.

@Zeymon onfirmed working but not in https. i've always tried to go to the http aria2ng but never thought to look inside uhttpd to disable auto redirect.
many thanks to you.

I simplified the installation if you want aria2/ariang in https: [solved] Aria2 : ssl/handshake failure : unable to get local issuer certificate with https links

install :

opkg install ca-certificates

cd /etc/ssl/

And run :

openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout server.key -out server.crt

Add in luci-app-aria2 options :

rpc-certificate=/etc/ssl/server.crt
rpc-private-key=/etc/ssl/server.key
rpc-secure=true
ca-certificate=/etc/ssl/certs/ca-certificates.crt

I went to this link with firefox (or any other) to sign the certificate and add an exception:

https://192.168.1.1:6800/jsonrpc

have a good day.

1 Like

Sorry for the late reply. I can also confirm this to be working. Using on LAN only, no security concern to me so. Thx a lot!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.