Trouble upgrading NETGEAR WNDR-4300v1 from 19.07 to 21.02


When I try to download 21.02 sysupgrade image for NETGEAR WNDR-4300v1 from the link provided at, nothing happens, file seems not to have been found, nothing is downloaded.

Then I tried to manually download it (netgear_wndr4300-squashfs-sysupgrade.bin) from

SHA256 of the downloaded file matches with the one published in the page above.


However when I try to use it from LuCI to upgrade from 19.07 to 21.02, I get the following error message:

Device wndr4300 not supported by this image Supported devices: netgear,wndr4300 Invalid sysupgrade file. Image check failed. The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.



Hi tmomas,

I did not chose to force upgrade because I'm not sure that the firmware is correct for my device.

I guess you are trying to tell me that it is correct.

Do you know the reason why I've got the error message below?

Device wndr4300 not supported by this image

Thanks, Jose

You have the correct image file, and this message is normal. I agree that it sounds alarming, I remember being suspicious myself.

Your device is similar to the 3700v4, and I had trouble upgrading from 19.07 to 21.02.

I would suggest not to upgrade from 19.07. Return to stock firmware, and than flash a 21.02 factory image. That works. Doing so, you can't keep settings and have to reconfigure from scratch. Once the device is on 21.02, you can safely upgrade while keeping settings (I went from RC3, RC4 to final).

1 Like

I have a wndr4300 and just did the upgrade. I attempted the force upgrade, but it ended up with the power led doing a slow green blink that the net tells me indicates firmware corruption. I did the tftp install instead, and it booted up fine.

I restored config from backup after that, which led to some minor issues:

Hope this helps.


Why does this not surprised me ? :wink:
Welcome to the club.

It would be wise to start configuration from scratch. Nevertheless, if the upgrade suits you and you find the configration stable, well ... go on.

Thank you for your recommendation, @badulesia. I'll do that.

Hi @badulesia, your suggestion of first going back from 19.07 to stock firmware before installing 21.02 worked fine for me. Thank you!

That's what I have done for a 3700v4, which is almost identical to a 4300.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.