Trouble setting up office network!

Hello All,

First a little background on my current situation. I am new to OpenWrt. In our office we currently have two separate ISPs. One fiber and one adsl. We purchased a Linksys WRT3200AC in hopes of installing OpenWRT so we could use the multiwan3 package.

I installed the latest openwrt package OpenWrt 18.06.2 and proceeded to start the setup

To start the process of moving both connections on the router I started first with the adsl line as to not impede the day to day operations of the office. I managed to place the router provided by the first isp to bridge mode.

Going back to the router I set up the wan connection on the router as PPPoE protocol with the user and password and after restarting both routers, I got a connection with a public ip address. Everything was going well from here, I managed to setup the firewall and the dhcp server, and proceeded to start adding all the devices to the network. At this point the first connection was done and it was working fine, everything was talking to everything.

Now came time to add the second wan to the equation. I used vlans to make another wan port and hooked that up to the other isp router. Being a piece of shit Vodafone router it dose not allow to do a classic pppoe connection but it forces you to use host-uniq command. Not knowing how to set that up, I googled a bunch and came across some old form from 2017 saying I needed to add another package to offer the support for host-uniq. So I added the packages, restarted the router...….. and nothing. The initial network (one I made first stopped getting internet). I tried to troubleshoot, deleted the packages (nothing happened), I went over all I made trying to figure out why I lost internet on my lan network.

Finally I went crazy and decided to start from scratch... so I reset everything all the routers. On the openwrt router I ran the command firstboot. I then started retracing my steps to get back to where I was before. Come to that point, when setting up the PPPoE for the first network again, the connection was being established, even getting a public ip address. But as soon as i wanted to ping anything... it said that the request timed out. Playing around with the settings lead me nowhere.

I then decided to flash the system with a sysupgrade bin which lead me back to where I started.

Now I am stuck.

Please can someone help me troubleshoot this, ive now wasted 4 full days trying to get this to work. Why cant I go back to the situation where the internet was connecting ?

here is the config flies please let me know if you need anything else.

Also thank you in advance for any help offered. I know ur awesome peeps

root@OpenWrt:~# vi /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdb7:4ef3:0b84::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option ifname 'eth1.2'
option proto 'pppoe'
option username 'aliceadsl'
option password 'aliceadsl'
option service 'Alice'
option ipv6 'auto'

config interface 'wan6'
option ifname 'eth1.2'
option proto 'dhcpv6'
option auto '0'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'

root@OpenWrt:~# vi /etc/config/firewall
config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT

config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT

config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1

config forwarding
option src lan
option dest wan

config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4

config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT

config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT

config rule
option name Allow-DHCPv6
option src wan
option proto udp
option src_ip fc00::/6
option dest_ip fc00::/6
option dest_port 546
option family ipv6
option target ACCEPT

config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT

config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp

config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option sequential_ip '1'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

In the device page I can see that LAN ports are in eth1 and WAN port in eth0.
Did you manually change that or was it by default vice versa?

What exactly is the behavior with these configs? Do you get WAN up addresses, an IPv6 prefix or what?

Everything you see in configs is stock expect the protocol for the wan.

The behavior is that I get the public ip address from the isp (its displayed in the interfaces page). When i go to do a ping i get that the servers sends 5 packets but dosent return anything. This means that the system is talking with the outside, but nothing gets in

Are you pinging an IP or a hostname?
I don't see any NS configured. Do you successfully acquire NS from your ISP?
What are the outputs of:

cat /tmp/resolv*
nslookup www.google.com
ping 8.8.8.8

pinging host returns the ip of the host, and then times out.

root@OpenWrt:~# cat /tmp/resolv*
search lan
nameserver 127.0.0.1
#Interface wan
nameserver 85.37.17.4
nameserver 85.38.28.70
nameserver 85.37.17.4
nameserver 85.38.28.70
root@OpenWrt:~# nslookup www.google.com
Server: 127.0.0.1
Address: 127.0.0.1#53

Name: www.google.com
Address 1: 172.217.23.100
Address 2: 2a00:1450:4002:805::2004

root@OpenWrt:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes

ping dosent even give the packet loss in the ssh consol. On the Webgui it gives this...

PING 8.8.8.8 (8.8.8.8): 56 data bytes

--- 8.8.8.8 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss

also attached a picture of the interfaces.

I find it a bit odd that LAN is on eth0.1 and WAN is on eth1.2 considering you are using VLANs. Although it may make sense if the device has a separate WAN port, does it have one?

Do you know that internet is actually coming through? Make sure to force a ping through ping -I pppoe-wan -c 5 8.8.8.8. It will use your connection to run a ping directly without the need for the default interface. This is helpful in case LAN to WAN forwarding is not working, which appears to be the case here.

Also make sure that Firewall is working. Head over to System -> Startup and see if it is enabled. Then look under Status -> Firewall and it should show you populated tables.

Could you try to set also WAN6 for PPPoE (same settings) and see if any of them will work?

A side note:
I noticed that the WAN gas MAC address for all zeros--not sure if this is normal.

It is odd as the router we choose has a dual core cpu. LAN is managed by the first cpu while both wans will be managed by the second cpu.

I tried the ping command you suggested and again it returned the same value. 5 Sent - 0 received

I checked the firewall to see if its on and it is, also the tables are populated

That is normal. I use my internet from my bridged router and for me the pppoe-wan shows no mac address. I have also another interface created so I can choose to access the modem's page and that interface correctly shows modem's mac.

Tried your suggestion and still no ping. Now both are on PPPoE and have 0 for the mac address. Im guessing the mac address is the on from the isp router which is in bridge mode... but I am not sure

Post here the whole output of iptables
iptables -L -vn ; iptables -t nat -L -vn ; iptables -t mangle -L -vn

Seems to me internet is not working after all. If you can, just connect to the modem itself from a PC and try to access internet there after configuring a pppoe connection on PC. It's possible you are not receiving any traffic from modem.

He is able to resolve google, so there might be some other block.

I connected the line directly to the modem and there is internet with pppoe on the pc. Also the internet work if I turn on the router back into routing mode. But the will give my double NAT problems. The internet is there, its just not coming in:(

Edit the previous posts and use Preformatted Text (Ctrl+Shift+C) to insert the output.
Also give the commands one by one because the router got overwhelmed and was using output as input, hence all these -ash: not found errors.

Here you go... sorry for the cluster fuck


  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.2, r7676-cddd7b4c77
 -----------------------------------------------------
root@OpenWrt:~# iptables -L -vn ;
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
  149 20110 ACCEPT     all  --  lo     *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */
 1064 92176 input_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom input rule chain */
  930 83328 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0            ctstate RELATED,ESTABLISHED /* !fw3 */
  100  4504 syn_flood  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            tcp flags:0x17/0x02 /* !fw3 */
   70  5840 zone_lan_input  all  --  br-lan *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */
   34  1372 zone_wan_input  all  --  pppoe-wan *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */
   30  1636 zone_wan_input  all  --  pppoe-wan6 *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain FORWARD (policy DROP 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
  672 69520 forwarding_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom forwarding rule chain */
    7   929 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0            ctstate RELATED,ESTABLISHED /* !fw3 */
  665 68591 zone_lan_forward  all  --  br-lan *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */
    0     0 zone_wan_forward  all  --  pppoe-wan *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */
    0     0 zone_wan_forward  all  --  pppoe-wan6 *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */
    0     0 reject     all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
  149 20110 ACCEPT     all  --  *      lo      0.0.0.0/0            0.0.0.0/0            /* !fw3 */
 1346  196K output_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom output rule chain */
 1260  189K ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0            ctstate RELATED,ESTABLISHED /* !fw3 */
    2   698 zone_lan_output  all  --  *      br-lan  0.0.0.0/0            0.0.0.0/0            /* !fw3 */
    0     0 zone_wan_output  all  --  *      pppoe-wan  0.0.0.0/0            0.0.0.0/0            /* !fw3 */
   84  5755 zone_wan_output  all  --  *      pppoe-wan6  0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain forwarding_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain forwarding_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain forwarding_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain input_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain input_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain input_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain output_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain output_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain output_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain reject (5 references)
 pkts bytes target     prot opt in     out     source               destination
   61  2476 REJECT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */ reject-with tcp-reset
    2   500 REJECT     all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */ reject-with icmp-port-unreachable

Chain syn_flood (1 references)
 pkts bytes target     prot opt in     out     source               destination
  100  4504 RETURN     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            tcp flags:0x17/0x02 limit: avg 25/sec burst 50 /* !fw3 */
    0     0 DROP       all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain zone_lan_dest_ACCEPT (4 references)
 pkts bytes target     prot opt in     out     source               destination
    2   698 ACCEPT     all  --  *      br-lan  0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain zone_lan_forward (1 references)
 pkts bytes target     prot opt in     out     source               destination
  665 68591 forwarding_lan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom lan forwarding rule chain */
  665 68591 zone_wan_dest_ACCEPT  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Zone lan to wan forwarding policy */
    0     0 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0            ctstate DNAT /* !fw3: Accept port forwards */
    0     0 zone_lan_dest_ACCEPT  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain zone_lan_input (1 references)
 pkts bytes target     prot opt in     out     source               destination
   70  5840 input_lan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom lan input rule chain */
    0     0 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0            ctstate DNAT /* !fw3: Accept port redirections */
   70  5840 zone_lan_src_ACCEPT  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain zone_lan_output (1 references)
 pkts bytes target     prot opt in     out     source               destination
    2   698 output_lan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom lan output rule chain */
    2   698 zone_lan_dest_ACCEPT  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain zone_lan_src_ACCEPT (1 references)
 pkts bytes target     prot opt in     out     source               destination
   70  5840 ACCEPT     all  --  br-lan *       0.0.0.0/0            0.0.0.0/0            ctstate NEW,UNTRACKED /* !fw3 */

Chain zone_wan_dest_ACCEPT (2 references)
 pkts bytes target     prot opt in     out     source               destination
    0     0 DROP       all  --  *      pppoe-wan  0.0.0.0/0            0.0.0.0/0            ctstate INVALID /* !fw3: Prevent NAT leakage */
    0     0 ACCEPT     all  --  *      pppoe-wan  0.0.0.0/0            0.0.0.0/0            /* !fw3 */
    0     0 DROP       all  --  *      pppoe-wan6  0.0.0.0/0            0.0.0.0/0            ctstate INVALID /* !fw3: Prevent NAT leakage */
  749 74346 ACCEPT     all  --  *      pppoe-wan6  0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain zone_wan_dest_REJECT (1 references)
 pkts bytes target     prot opt in     out     source               destination
    0     0 reject     all  --  *      pppoe-wan  0.0.0.0/0            0.0.0.0/0            /* !fw3 */
    0     0 reject     all  --  *      pppoe-wan6  0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain zone_wan_forward (2 references)
 pkts bytes target     prot opt in     out     source               destination
    0     0 forwarding_wan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom wan forwarding rule chain */
    0     0 zone_lan_dest_ACCEPT  esp  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Allow-IPSec-ESP */
    0     0 zone_lan_dest_ACCEPT  udp  --  *      *       0.0.0.0/0            0.0.0.0/0            udp dpt:500 /* !fw3: Allow-ISAKMP */
    0     0 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0            ctstate DNAT /* !fw3: Accept port forwards */
    0     0 zone_wan_dest_REJECT  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain zone_wan_input (2 references)
 pkts bytes target     prot opt in     out     source               destination
   64  3008 input_wan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom wan input rule chain */
    0     0 ACCEPT     udp  --  *      *       0.0.0.0/0            0.0.0.0/0            udp dpt:68 /* !fw3: Allow-DHCP-Renew */
    1    32 ACCEPT     icmp --  *      *       0.0.0.0/0            0.0.0.0/0            icmptype 8 /* !fw3: Allow-Ping */
    0     0 ACCEPT     2    --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Allow-IGMP */
    0     0 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0            ctstate DNAT /* !fw3: Accept port redirections */
   63  2976 zone_wan_src_REJECT  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain zone_wan_output (2 references)
 pkts bytes target     prot opt in     out     source               destination
   84  5755 output_wan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom wan output rule chain */
   84  5755 zone_wan_dest_ACCEPT  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain zone_wan_src_REJECT (1 references)
 pkts bytes target     prot opt in     out     source               destination
   34  1372 reject     all  --  pppoe-wan *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */
   29  1604 reject     all  --  pppoe-wan6 *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */






root@OpenWrt:~# iptables -t nat -L -vn
Chain PREROUTING (policy ACCEPT 598 packets, 72237 bytes)
 pkts bytes target     prot opt in     out     source               destination
  598 72237 prerouting_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom prerouting rule chain */
  517 68633 zone_lan_prerouting  all  --  br-lan *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */
   34  1372 zone_wan_prerouting  all  --  pppoe-wan *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */
   30  1620 zone_wan_prerouting  all  --  pppoe-wan6 *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain INPUT (policy ACCEPT 45 packets, 2992 bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain OUTPUT (policy ACCEPT 72 packets, 5465 bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain POSTROUTING (policy ACCEPT 11 packets, 1299 bytes)
 pkts bytes target     prot opt in     out     source               destination
  468 63473 postrouting_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom postrouting rule chain */
    2   698 zone_lan_postrouting  all  --  *      br-lan  0.0.0.0/0            0.0.0.0/0            /* !fw3 */
    0     0 zone_wan_postrouting  all  --  *      pppoe-wan  0.0.0.0/0            0.0.0.0/0            /* !fw3 */
  457 62174 zone_wan_postrouting  all  --  *      pppoe-wan6  0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain postrouting_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain postrouting_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain postrouting_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain prerouting_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain prerouting_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain prerouting_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain zone_lan_postrouting (1 references)
 pkts bytes target     prot opt in     out     source               destination
    2   698 postrouting_lan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom lan postrouting rule chain */

Chain zone_lan_prerouting (1 references)
 pkts bytes target     prot opt in     out     source               destination
  517 68633 prerouting_lan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom lan prerouting rule chain */

Chain zone_wan_postrouting (2 references)
 pkts bytes target     prot opt in     out     source               destination
  457 62174 postrouting_wan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom wan postrouting rule chain */
  457 62174 MASQUERADE  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain zone_wan_prerouting (2 references)
 pkts bytes target     prot opt in     out     source               destination
   64  2992 prerouting_wan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom wan prerouting rule chain */







root@OpenWrt:~# iptables -t mangle -L -vn
Chain PREROUTING (policy ACCEPT 2225 packets, 212K bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain INPUT (policy ACCEPT 1339 packets, 122K bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain FORWARD (policy ACCEPT 729 packets, 79572 bytes)
 pkts bytes target     prot opt in     out     source               destination
    0     0 TCPMSS     tcp  --  *      pppoe-wan  0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* !fw3: Zone wan MTU fixing */ TCPMSS clamp to PMTU
  552 28704 TCPMSS     tcp  --  *      pppoe-wan6  0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* !fw3: Zone wan MTU fixing */ TCPMSS clamp to PMTU

Chain OUTPUT (policy ACCEPT 1582 packets, 238K bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain POSTROUTING (policy ACCEPT 2313 packets, 319K bytes)
 pkts bytes target     prot opt in     out     source               destination
root@OpenWrt:~#

It is very strange that no IPv4 is used.

    0     0 zone_wan_output  all  --  *      pppoe-wan  0.0.0.0/0            0.0.0.0/0            /* !fw3 */
   84  5755 zone_wan_output  all  --  *      pppoe-wan6  0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Can you try to ping6 ipv6.google.com or use the IPv6 option in ping diagnostics in Luci?
Some suggestions:

  1. Set MTU 1492 for the PPPOE interface. it is under Advanced Tab in WAN interface.
  2. Unless specifically instructed from ISP, remove service Alice from WAN interface.

So, I set the desired config to MTU and tried both on the console and on Luci and im getting this

PING openwrt.org (2a03:b0c0:3:d0::1af1:1): 56 data bytes
ping6: sendto: Permission denied

root@OpenWrt:~# ping6 ipv6.google.com
PING ipv6.google.com (2a00:1450:4002:80b::200e): 56 data bytes
ping6: sendto: Permission denied
root@OpenWrt:~#