Trouble instaling a NTFS external disk

Hello Friends,

I downloaded and installed your firmware version 18.06.2 on a Linksys WRT1900ACV1. Now I am trying to install support for NTFS, but the console answers for packages: kmod-fs-ntfs and ntfs-3g:
Unknow package 'name-package'
opkg_install_cmd: Cannot install package name-package

Can you tell advice me, on how to install these packages. Also I want to share this external disk in my local network.

Thanks in advance

Have you tried

opkg update
opkg install kmod-fs-ntfs
opkg install ntfs-3g

or updating the package list and installing them through LuCI?

The package lists are kept on a RAM-backed temporary file system, so they need to be fetched (opkg update) before they have any content after every boot. It's a good idea to fetch them before any install.

You may need some other packages to get the WRT1900 to recognize USB storage, but I don't know that unit well enough to know what is already installed.


Hello Jeff,

Thanks for your fast and useful answer. I was missing opkg update line. I'm newbie.

Best regards


If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


1 Like

THANK YOU SO MUCH!!!! :smiley::smiley: I've been going nuts with these packages not installing. With the opkg update in front allows it to work every time!!!:+1:

They should make a note of this a lot more in the OpenWrt tutorials, especially with hooking up USB drives. Finally got NTFS drives working.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.