Trouble accessing certain websites

is there a way to set mtu's independently? maybe 1428 for ipv6 and 1492 for ipv4?

You will not lose much setting 1360 as cloudflare does.

2 Likes

Yes you can independently set them, but indeed just bulk changing it to 1448 or 1360 does not cost that much bandwidth

Any idea how you derived 1448?

For the 1448 see above from egc

1 Like
cat /etc/nftables.d/mssfix.nft 
chain mangle_postrouting {
               type filter hook postrouting priority mangle; policy accept;
               oif $wan_devices tcp flags syn / syn,fin,rst tcp option maxseg size set rt mtu
}

eq.

I'm sorry, should I apply this fix? I tried this fix earlier but it didn't seem to change the situation

It wi;ll be there in next release, just save a file /etc/nftables.d/something.nft with cotent:

chain mangle_postrouting {
               type filter hook postrouting priority mangle; policy accept;
               oif $wan_devices tcp flags syn / syn,fin,rst tcp option maxseg size set rt mtu
}

Then tune interface MTU to whatever UDP and ICMP indicates.
It is discussed here:

Current code sets MSS to match incoming interface MTU i.e no-op.

1 Like

Thanks for all the help, I will monitor the situation regarding IPv6 with my ISP and update in a new thread. So far the fix was mssfix.nft and setting the MTU for pppoe-wan to 1452 (pinging from router allowed upto 1404 bytes to be sent for ipv6).

1 Like