Trelay wifi repeater configuration

I use the latest OpenWrt 18.06.2, r7676-cddd7b4c77 on a tplink-wr740-v4.2. I want to set up a wifi repeater for the local wifi network using kmod-trelay. I don't use "relayd" because it doesn't relay DHCP datagrams. My configuration is the following:

/etc/config/network

config interface 'wwan'
        option proto 'unmanaged'

/etc/config/wireless

config wifi-iface
        option device 'radio0'
        option network 'wwan'
        option mode 'ap'
        option ssid 'repeater'
        option encryption 'psk2'
        option key 'passphrase'
        option ifname "wlan0"

config wifi-iface
        option network 'wwan'
        option ssid 'origin-wifi'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option key 'passphrase'
        option ifname "wlan1"

/etc/config/trelay

config trelay
        option enabled  1
        option dev1     wlan0
        option dev2     wlan1

When I run /etc/init.d/treay start and connect to "repeater", dhcp didn't manage to get a response.
I don't see any DHCP broadcasts in the origin network. Also, I can't run tcpdump on the router because of the insufficient space for the installation. Can anyone point me to the working solution?

Did you manage to resolve this?

I did in another way, when configured master and client wifi and setup masquerade in between. Not an optimal way, but it was simplier.