Travelrouter with VPN to Home-Fritzbox

Hello everyone,

I've one Problem with my VPN. This weekend we will go to vacation so I need a little help to find my problem.

OpenWrt Router is the GL-iNet GL-AR300M16 with GL-firmware. I've added Luci and VPNC. The OpenWrt-Router is working is in Router Mode. Internet connection is actual W-Lan Tethering from an iPhone. In the Fritzbox I've created an user an the VPN-connection is working (green light at Fritzbox and the correct IP is shown at Interfaces).

What should I do to route the full data via my Fritzbox to the internet?

Your GL-iNet device is not running an official OpenWrt version if you are using the firmware from the vendor. I would recommend asking on the GL-iNet forums to get assistance since there are enough differences between official OpenWrt and their version that advice here will not likely get you running properly.

Is your Fritzbox running the vendor firmware or official OpenWrt?


The default setup is for what you want: the travel router (client) routes all of its users' Internet usage through the VPN tunnel to the home router (server) and from there it goes out to the Internet. What in particular is not working? Examine the route table of both devices.

When you test this at home it will not work to connect the travel router to the home network (wifi or wired) You need to fully simulate traveling by using a separate Internet connection like the iPhone.

And what psherman said, you should be running official OpenWrt at both ends to get much useful help in this particular forum.

1 Like

At the GI Router is the Vendor OpenWrt Version installed. I try today an empty Version but from my point of view I need to much work to make it ready to work like I want. So I will forward it a little.

On Fritzbox there is the official Firmware, no OpenWrt.

The GI is connected with LTE to the Internet via iPhone Wlan. VPN-Tunnel via VPNC at GI, at Fritzbox the included IP-sec.

From with the GI connected Laptop I've no access to other Network Devices in my Home network. And when I make a IP-check the iPhone IP is shown, not the Fritzbox IP.

The Question is where is the Problem. From my point of view I have to disable the normal route and enable instead the VPN Route. And the best solution will be to use the hardware switch to change between VPN and direct Internet. If the children wants to stream something or I want to the Smart Home I switch and the VPN will work.

I'm an electrical engineer with network knowledge and CCNA zertification but I start with OpenWrt at first on Thuesday, so some coherences are not clear for me.

Since neither of your devices run openwrt, you should ask on forums dedicated to those systems.

1 Like