Travelmate support thread


#21

I have travelmate installed on another router with latest lede 17.01.4
I want to connect to AP with WPA enterprise security
However I got error after add in SSID
Below show error
Any chance to fix it?

/usr/lib/lua/luci/dispatcher.lua:478: Failed to execute cbi dispatcher target for entry '/admin/services/travelmate/wifiadd'.
The called action terminated with an exception:
/usr/lib/lua/luci/model/cbi/travelmate/wifi_add.lua:61: attempt to index global 'wkey' (a nil value)
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:478: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:121: in function </usr/lib/lua/luci/dispatcher.lua:120>

#22

You can edit enterprise STAs (to change the password) but adding new enterprise STAs is not supported yet. In the meantime edit directly /etc/config/wireless and add those stations manually.


#23

Hello!

Thank's a lot for this great piece of software you created! I always wanted to have this functionality - with travelmate it's a pleasure :grinning:

I just have one big problem on one of my devices (a5-v11, rt3050x device). I was running a old version here (without the nice gui for adding stations etc.) and wanted to have the most recent version.

I builded a new firmware with the image builder and I included the most recent versions directly:

  • travelmate 0.9.3-1
  • luci-app-travelmate git-17.336.23170-d2dc32a-1

but my problem is that I have STILL the 'old' interface. I flashed the firmware without keeping settings. I also did a factory reset afterwards when I saw the old gui - but still it's here, very wierd!

I also tried to fix it with resetting the luci caches - no luck...

/etc/init.d/uhttpd stop
rm -f /tmp/luci-indexcache
rm -rf /tmp/luci-modulecache
/etc/init.d/uhttpd start

old-gui-pfui

I did the same (exactly the same!) procedure for a ARV752DPW22 (lantiq) device and here everything is like it should. Just the luci-app-travelmate is a bit 'older'

  • travelmate 0.9.3-1
  • luci-app-travelmate git-17.328.04231-802d5b6-1

#24

Hi,

thanks for your feedback. The version above is from the stable 17.01.x package tree - therefore the old version is included. Please download & install from the snapshot package tree. You can safely use the download links of the initial post, travelmate is architecture independent.


#25

Thanks for this information! Wierd is the fact that I builded both versions in the exact same way (with providing the downloaded *.ipk's in the local package folder while using the imagebuilder). And the results in the builded images are different.

Anyway, downgrading is not possible anymore inside the running system so I need to build a new image...

Litte offtopic but do you know how I can force the imagebuilder to include the local package and not the one provided from the lede server?

Thanks again for sharing your great work (also including adblocker :grin:)


#26

I can see a lot of positive feedback about Travelmate. Could you please help in setting it up properly?

I use the Wifi Tethering on my mobile to connect to the internet. The repeater for my mobile hotspot is my TP-Link (TL-WA701ND).

I followed this link on how to setup the repeater.

Here is my current configuration:

  • LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)
  • travelmate 0.9.3-1
  • luci-app-travelmate git-17.328.04231-802d5b6-1

Wireless Configuration

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ar933x_wmac'
	option htmode 'HT20'
	option country 'US'
	option channel 'auto'

config wifi-iface
	option network 'trm_wwan'
	option ssid 'ETH-Mobile'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'sta'
	option bssid '02:1A:11:F7:03:FB'
	option key 'xxx'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'ETH-QTR'
	option network 'lan'
	option hidden '1'
	option encryption 'psk2'
	option key 'xxxx'

Travelmate Configuration

# travelmate configuration, for further information
# see 'https://github.com/openwrt/packages/blob/master/net/travelmate/files/README.md'

config travelmate 'global'
	option trm_enabled '1'
	option trm_debug '0'
	option trm_triggerdelay '1'
	option trm_automatic '1'
	option trm_maxwait '30'
	option trm_maxretry '3'
	option trm_timeout '60'
	option trm_iface 'trm_wwan'
	option trm_rtfile '/tmp/trm_runtime.json'

Network Configuration

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd3e:fb82:2f43::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'trm_wwan'
	option proto 'dhcp'

#27

Hopefully, but what's your problem actually!? :wink:
Just a rough guess ... you can't use travelmate to connect to hidden networks - this is not supported.
If you have other connection problems, please enable debugging and post your travelmate log.

Thanks.


#28

Once again: travelmate is very nice piece of work! :top:

Here are some features from my wish list for travelmate 2.0 :relaxed:

  • setting to use random [or from list] mac address on the uplink interface
  • setting to use random [or from list] hostname on the uplink interface
  • setting to use random [or from list] mac address on the ap interface
  • setting to use random from list 'ssid & password' on the ap interface
  • setting to use a physical rj45 jack as uplink interface
  • setting to use 3g/4g-modem with sim as uplink interface
  • setting to ignore DNS-Server advised from the uplink interface and use the one set
  • setting to ignore ipv6 advised from the uplink

#29

Well, that's sounds like a far call ... :smiley:
Currently I'm working on support for hidden uplinks and wpa enterprise uplinks - stay tuned.


#30

OK, now it's not hidden.

The problem is that when "ETH-Mobile" is back in range the router still doesn't detect it. It says "Wireless is disabled or not associated".


#31

As I said before, please post travelmate related debug logs, if you run into connection problems. BTW, the message above does not com from travelmate ...


#32

Just for your information: the latest travelmate version 0.9.6 adds support for ...

  • hidden uplinks and
  • wpa enterprise uplinks

The latter one is more or less untested, would be nice if someone could test that.

Thanks!
Dirk


#33

I replaced the hotspot device "ETH-Mobile" with a new one and everything seems to be working normal. Thank you :slight_smile:


#34

Thanks for your packages.
I am using LEDE 17.04 r3608 tp-link 720nv3 with travelmate 0.9.6. It's working nicely with non-hidden ssids. However, it keeps picking a weak non-hidden ssid instead of a hidden uplink right beside me. I checked that the related password in wireless conf file was correct, and the hidden uplink was working normally.
Would you please give me a hint e.g. to add some option in the conf files in order to let travelmate tries to connect hidden uplinks?


#35

Travelmate iterates through all configured STAs in your wireless config. In the wireless stations overview you can simply move up/move down those stations, e.g. place the hidden STA in the first place ...


#36

Thanks for your reply. I tend to edit conf file directly since my device memroy is too small to accommodate the luci interface.
To my understanding, move up STAs, that's the higher priority of STA, the lower line number of the related STA section in wireless conf. Correct?


#37

yes! :slightly_smiling_face:


#38

I'm happily using Travelmate on a Zsun device. However, when I connect to a network with multiple APs (such as in a hotel or a business) I have to connect to a specific AP based on BSSID. As such, when I physically move my device, I will lose connection when the selected AP becomes out of range. I'd like Travelmate to roam to the strongest available AP within the same network (based on SSID) in the same way a Windows- or mobile device would. Is this a feature that's possible for a future version?


#39

No, the BSSID is complete optional - it's only required for hidden networks. If you like to connect to multiple APs with the same SSID simply remove the BSSID information and you're connected ... :sunglasses:

Best wishes for 2018!


#40

Ah that's great to know! Then maybe for a feature version make this a checkbox when connecting? ("Do not save BSSID" or something similar?)

Frohes neues Jahr!