Transmission rpc error on fresh installation (21.02.1)

if you're referring to snapshots, those shouldn't be updated, by applying newer packages, you risk bricking your device.

No. I'm not speaking about snapshots.
I only use the official and stable releases.
The updates I'm speaking about are the packages available via OPKG updates.

Thanks for the information. I'll try to wait for the next update to see if they fix this bug.
I'm more annoyed that this is a version called stable release and such a bug occurs in it.

Same here !
Hope a fix could be released soon

I played with this, and got it to work, seems the config file located in /root/.config/transmission-daemon/settings.json doesn't get the settings from /etc/config/transmission copied correctly.

If you manually add the rpc whitelist IPs (in two locations) to the settings.json it works,
at least for me, in 21.02.1.
Don't forget to enable the rpc whitelists, too.

You might want to give it a go, @supertack, @jdwl1o1 and @csordit.

the /root/ part of the path might differ, if you use another user for running transmission.

Thanks Frollic,
I have correct configuration in the "settings.json" file. But unfortunately, the RPC always gives "Connection refused" error message.

Have you tried to update the packages?

For me, one of the updates broke the RPC.

I DLed it today, so I would assume the most recent one got installed.

feel tree to post your settings.json.

you could also run transmission-daemon -f, to see the output during initialization.

My config file location is /usb_hdd/transmission/settings.json
If i change the config with LUCI, it will modify this file. So far so good.

If i run the command "transmission-daemon -f" a new settings.json file will be created in "root/.config/transmission-daemon" folder, but with incorrect contents.
If I overwrite this file with the correct configuration and run "transmission-daemon -f", the RPC works perfectly.
However, when I stop the command (ctrl + c), the RPC connection refuse again.

Do you have idea why RPC only works when running the "transmission-daemon -f" command?

No idea, I'll try ro look into it tomorrow again.

Didn't think fg and bg execution would make any difference..

Thanks.
I set up my transmission to work in the /usb_hdd/transmission directory. This is where the settings.json file and the "torrents", "resume", "blocklists" directories were created.
However, if I run the "transmission-deamon -f" command, it creates these files and directories in /root/.config/transmission-deamon" and wants to use them. I don't know why.

transmission starts with a user transmission, not root, when run as a service, the corresponding settings.json is then stored in /tmp/transmission, this appears to be working, and populate correctly.

however the daemon needs to be enabled in /etc/config/transmission, to be able to start it as a service.

the default value's option enabled 0, and needs to be set to 1.

Hi all,

I've spent a couple of hours testing all packages that were available on the OpenWRT 21.02.1 and it looks like transmission stops working after installing this particular package:

I've checked the package version in luci an it showed me this:

If you avoid this one for now you should be fine.

I'm sorry, I was unable to do new tests as I really need Transmission so I had to keep it untouched after install...

@frollic: if we keep settings.json stored in /tmp/transmission, it will be deleted after each reboot ?

yes, /tmp gets wiped.

Well. My config file is located at /etc/transmission. As I said before, I only make it working when disabling all the system updates and keeping the settings in this way:

Capture d’écran 2022-02-24 101642

I hope we can have a fix soon to benefit from future updates.

any update about it? still not working here

There is no update as I know...
I only kept OpenWRT untouched with no updates to use it...

1 Like

I can't make it work here

Any news about this problem ?
Transmission or its dependencies have been fixed ?

I don't use it for a while, did not work