Transmission rpc error on fresh installation (21.02.1)

Hello dears,
I'm using OpenWrt and Transmission for few years on my NAS (MyBookLive, from Western Digital), without any problems.

I replaced the HDD of my NAS today, so I did a fresh and clean install of OpenWrt version 21.0.2.1. Unfortunately, I can'y get Transmission working as usual.

I installed transmission as usual:

opkg update
opkg install transmission-daemon
opkg install transmission-cli
opkg install transmission-web
opkg install transmission-remote
opkg install luci-app-transmission

Then:

uci set transmission.@transmission[0].enabled="1"
uci commit transmission
/etc/init.d/transmission restart

I got the Transmission entry in LuCi but when I open the Transmission web interface, I got an error : ERR_CONNECTION_REFUSED

If I manually start the daemon with SSH (transmission-daemon -f), I got another error:

# 403: Forbidden
Unauthorized IP Address.
Either disable the IP address whitelist or add your address to it.
If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.
If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.

So, I have two problems:

  1. Transmission doesn't autostart at each reboot
  2. If I manually start it using SSH, I cannot access to the web interface, even if I tried all the combinations (disabling or enabling RPC whitelist, indicating the authorized IP...)

When reading the logs, it seems that there is a loop with Transmission.

This is my configuration:

config transmission
	option config_overwrite '1'
	option mem_percentage '50'
	option nice '10'
	option alt_speed_enabled 'false'
	option alt_speed_time_enabled 'false'
	option bind_address_ipv4 '0.0.0.0'
	option bind_address_ipv6 '::'
	option blocklist_enabled 'false'
	option cache_size_mb '2'
	option dht_enabled 'true'
	option download_queue_enabled 'true'
	option download_queue_size '4'
	option encryption '1'
	option idle_seeding_limit_enabled 'false'
	option lazy_bitfield_enabled 'true'
	option message_level '1'
	option peer_limit_global '240'
	option peer_limit_per_torrent '60'
	option peer_port_random_on_start 'false'
	option peer_socket_tos 'default'
	option pex_enabled 'true'
	option queue_stalled_enabled 'true'
	option queue_stalled_minutes '30'
	option ratio_limit_enabled 'false'
	option rename_partial_files 'true'
	option rpc_bind_address '0.0.0.0'
	option rpc_enabled 'true'
	option rpc_host_whitelist_enabled 'false'
	option rpc_port '9091'
	option scrape_paused_torrents_enabled 'true'
	option script_torrent_done_enabled 'false'
	option seed_queue_enabled 'false'
	option speed_limit_down_enabled 'false'
	option speed_limit_up_enabled 'false'
	option start_added_torrents 'true'
	option umask '18'
	option upload_slots_per_torrent '14'
	option utp_enabled 'true'
	option scrape_paused_torrents 'true'
	option watch_dir_enabled 'false'
	option config_dir '/etc/config/transmission'
	option download_dir '/mnt/sda4/Public/Torrents/'
	option incomplete_dir_enabled 'true'
	option incomplete_dir '/mnt/sda4/Public/Torrents/Incomplets/'
	option preallocation '0'
	option trash_original_torrent_files 'true'
	option lpd_enabled 'true'
	option prefetch_enabled '1'
	option peer_port '50000'
	option port_forwarding_enabled 'false'
	option peer_id_ttl_hours 'root'
	option rpc_whitelist_enabled 'true'
	option rpc_whitelist '127.0.0.1,*.*.*.*'
	option rpc_authentication_required 'true'
	option rpc_username 'admin'
	option rpc_password 'mypassword'
	option enabled '1'
	option user 'root'
	option group 'root'

Any idea on how to fix it ? Could it be related to OpenSSL as I red on some forums ?

Thanks!

Change whitelist enabled to false or add your internal subnet to the whitelist

Thanks, but already tried and not working...

Ok, can you share the config after disabling? The one above has it enabled.

Check the log after trying to access, should say something useful

Well, in case it could help someone:

If I do a fresh install of OpenWrt and then I install Transmission using LuCi web interface, it works.

If I install the system updates, before of after Transmission installation, Transmission doesn't work anymore.

If Transmission works and then I modify the RPC settings (login/password to access RPC, Whitelist...), then Transmission doesn't work anymore.

I'm not sure, but I think the problem is due to WolfSSL dependency.

I can stay at this configuration, but it's sad to not being able to install system updates nor securing Transmission RPC...

Thanks.

Hi All,
Unfortunately, I have a similar problem. I have used Transmission for years without any problems. However, since the last update I can't connect to it. The RPC does not work. It refuses to connect.
(OpenWrt 21.02.1, transmission-daemon 3.00-12)
Please someone help us to solve the problem.
Thanks,Tamas

The only "fix" I've found is to install Transmission immediately after a fresh setup of OpenWrt 21.02.01, without installing any system update and whithout setting up the Transmission's RPC (you have to keep it as it, whitout password nor whitelist...)

Hope the maintainers could fix this annoying problem.

if you're referring to snapshots, those shouldn't be updated, by applying newer packages, you risk bricking your device.

No. I'm not speaking about snapshots.
I only use the official and stable releases.
The updates I'm speaking about are the packages available via OPKG updates.

Thanks for the information. I'll try to wait for the next update to see if they fix this bug.
I'm more annoyed that this is a version called stable release and such a bug occurs in it.

Same here !
Hope a fix could be released soon

I played with this, and got it to work, seems the config file located in /root/.config/transmission-daemon/settings.json doesn't get the settings from /etc/config/transmission copied correctly.

If you manually add the rpc whitelist IPs (in two locations) to the settings.json it works,
at least for me, in 21.02.1.
Don't forget to enable the rpc whitelists, too.

You might want to give it a go, @supertack, @jdwl1o1 and @csordit.

the /root/ part of the path might differ, if you use another user for running transmission.

Thanks Frollic,
I have correct configuration in the "settings.json" file. But unfortunately, the RPC always gives "Connection refused" error message.

Have you tried to update the packages?

For me, one of the updates broke the RPC.

I DLed it today, so I would assume the most recent one got installed.

feel tree to post your settings.json.

you could also run transmission-daemon -f, to see the output during initialization.

My config file location is /usb_hdd/transmission/settings.json
If i change the config with LUCI, it will modify this file. So far so good.

If i run the command "transmission-daemon -f" a new settings.json file will be created in "root/.config/transmission-daemon" folder, but with incorrect contents.
If I overwrite this file with the correct configuration and run "transmission-daemon -f", the RPC works perfectly.
However, when I stop the command (ctrl + c), the RPC connection refuse again.

Do you have idea why RPC only works when running the "transmission-daemon -f" command?

No idea, I'll try ro look into it tomorrow again.

Didn't think fg and bg execution would make any difference..

Thanks.
I set up my transmission to work in the /usb_hdd/transmission directory. This is where the settings.json file and the "torrents", "resume", "blocklists" directories were created.
However, if I run the "transmission-deamon -f" command, it creates these files and directories in /root/.config/transmission-deamon" and wants to use them. I don't know why.

transmission starts with a user transmission, not root, when run as a service, the corresponding settings.json is then stored in /tmp/transmission, this appears to be working, and populate correctly.

however the daemon needs to be enabled in /etc/config/transmission, to be able to start it as a service.

the default value's option enabled 0, and needs to be set to 1.

Hi all,

I've spent a couple of hours testing all packages that were available on the OpenWRT 21.02.1 and it looks like transmission stops working after installing this particular package:

I've checked the package version in luci an it showed me this:

If you avoid this one for now you should be fine.

I'm sorry, I was unable to do new tests as I really need Transmission so I had to keep it untouched after install...

@frollic: if we keep settings.json stored in /tmp/transmission, it will be deleted after each reboot ?