TPlink MR-6400 ping problem

the problem is very strange with this router I can't ping outside but after I edit lan config which is not important change or not change anything ,it's working. after reboot again ping not and I edit again

The ping is not working from the router or some host in the lan?

from the router

Post here the output of the following after reboot.
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; \
ping -c 3 8.8.8.8 ; ping6 -c 3 2a00:1450:4014:80d::200e ; ping -c 3 google.com ; ifstatus wan; ifstatus wan6; ifstatus wan_6

Use the "Preformatted text </> " button for clarity:
grafik
Then do your magic and post them again.

 ; ifstatus wan; ifstatus wan6; ifstatus wan_6
{
        "kernel": "4.14.180",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros QCA9533 ver 2 rev 0",
        "model": "TP-Link TL-MR6400 v1",
        "board_name": "tl-mr6400",
        "release": {
                "distribution": "OpenWrt",
                "version": "19.07.3",
                "revision": "r11063-85e04e9f46",
                "target": "ar71xx/generic",
                "description": "OpenWrt 19.07.3 r11063-85e04e9f46"
        }
}
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd46:1a3f:7609::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1 eth1'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'
        option gateway '192.168.1.254'
        list dns '8.8.8.8'
        list dns '1.1.1.1'
        option broadcast '192.168.1.2'

config interface 'wan'
        option proto 'dhcp'
        option delegate '0'
        option ifname 'usb0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 0t'

package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca953x_wmac'
        option htmode 'HT20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option network 'lan'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option netmask '255.255.255.0'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config include 'shadowsocks'
        option type 'script'
        option path '/var/etc/shadowsocks.include'
        option reload '1'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group defaul                                                                  t qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
5: usb0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN                                                                   group default qlen 1000
    inet 192.168.0.158/24 brd 192.168.0.255 scope global usb0
       valid_lft forever preferred_lft forever
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP gro                                                                  up default qlen 1000
    inet 192.168.1.2/24 brd 192.168.1.2 scope global br-lan
       valid_lft forever preferred_lft forever
default via 192.168.0.1 dev usb0 proto static src 192.168.0.158
192.168.0.0/24 dev usb0 proto kernel scope link src 192.168.0.158
192.168.1.0/24 dev br-lan proto kernel scope link src 192.168.1.2
broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0                                                                  .1
broadcast 192.168.0.0 dev usb0 table local proto kernel scope link src 192.168.0                                                                  .158
local 192.168.0.158 dev usb0 table local proto kernel scope host src 192.168.0.1                                                                  58
broadcast 192.168.0.255 dev usb0 table local proto kernel scope link src 192.168                                                                  .0.158
broadcast 192.168.1.0 dev br-lan table local proto kernel scope link src 192.168                                                                  .1.2
local 192.168.1.2 dev br-lan table local proto kernel scope host src 192.168.1.2                                                                  
broadcast 192.168.1.2 dev br-lan table local proto kernel scope link src 192.168                                                                  .1.2
broadcast 192.168.1.255 dev br-lan table local proto kernel scope link src 192.1                                                                  68.1.2
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::3e46:d8ff:fe8c:6069/64 scope link
       valid_lft forever preferred_lft forever
5: usb0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80::54d8:62ff:fe13:a56f/64 scope link
       valid_lft forever preferred_lft forever
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd46:1a3f:7609::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::3e46:d8ff:fe8c:6069/64 scope link
       valid_lft forever preferred_lft forever
8: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::3e46:d8ff:fe8c:606a/64 scope link
       valid_lft forever preferred_lft forever
fd46:1a3f:7609::/64 dev br-lan proto static metric 1024 pref medium
unreachable fd46:1a3f:7609::/48 dev lo proto static metric 2147483647 error 4294                                                                  967148 pref medium
fe80::/64 dev usb0 proto kernel metric 256 pref medium
fe80::/64 dev eth0 proto kernel metric 256 pref medium
fe80::/64 dev br-lan proto kernel metric 256 pref medium
fe80::/64 dev wlan0 proto kernel metric 256 pref medium
local ::1 dev lo table local proto kernel metric 0 pref medium
anycast fd46:1a3f:7609:: dev br-lan table local proto kernel metric 0 pref mediu                                                                  m
local fd46:1a3f:7609::1 dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev usb0 table local proto kernel metric 0 pref medium
anycast fe80:: dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0 table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan0 table local proto kernel metric 0 pref medium
local fe80::3e46:d8ff:fe8c:6069 dev br-lan table local proto kernel metric 0 pre                                                                  f medium
local fe80::3e46:d8ff:fe8c:6069 dev eth0 table local proto kernel metric 0 pref                                                                   medium
local fe80::3e46:d8ff:fe8c:606a dev wlan0 table local proto kernel metric 0 pref                                                                   medium
local fe80::54d8:62ff:fe13:a56f dev usb0 table local proto kernel metric 0 pref                                                                   medium
ff00::/8 dev br-lan table local metric 256 pref medium
ff00::/8 dev usb0 table local metric 256 pref medium
ff00::/8 dev eth0 table local metric 256 pref medium
ff00::/8 dev wlan0 table local metric 256 pref medium
0:      from all lookup local
32766:  from all lookup main
4200000001:     from all iif lo failed_policy
4200000005:     from all iif usb0 failed_policy
4200000006:     from all iif br-lan failed_policy
ls: /tmp/resolv.*/*: No such file or directory
lrwxrwxrwx    1 root     root            16 May 16  2020 /etc/resolv.conf -> /tm                                                                  p/resolv.conf
-rw-r--r--    1 root     root            32 Nov 15 16:43 /tmp/resolv.conf
-rw-r--r--    1 root     root            93 Nov 15 16:43 /tmp/resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf.auto <==
# Interface lan
nameserver 8.8.8.8
nameserver 1.1.1.1
# Interface wan
nameserver 192.168.0.1
head: /tmp/resolv.*/*: No such file or directory
PING 8.8.8.8 (8.8.8.8): 56 data bytes

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss
PING 2a00:1450:4014:80d::200e (2a00:1450:4014:80d::200e): 56 data bytes
ping6: sendto: Permission denied
ping: bad address 'google.com'
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 339,
        "l3_device": "usb0",
        "proto": "dhcp",
        "device": "usb0",
        "updated": [
                "addresses",
                "routes",
                "data"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": false,
        "ipv4-address": [
                {
                        "address": "192.168.0.158",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "192.168.0.1",
                        "source": "192.168.0.158/32"
                }
        ],
        "dns-server": [
                "192.168.0.1"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "hostname": "OpenWrt",
                "leasetime": 7200
        }
}
Interface wan6 not found
Interface wan_6 not found

Your lan interface is a mess.

  1. Change IP address back to 192.168.1.1
  2. Remove the dns servers from lan. You can add them in the wan if you want.
  3. Delete the broadcast, it is wrong.
  4. Option netmask is not needed in lan dhcp configuration.
  5. Delete the gateway from lan interface.