TPLink bricked after rolling back to stop (following tutorial)

Hi people!
Until today i've had a TPLink archer C7 v4 running OpenWRT perfectly. I've upgraded my internet connection to 1gbps but I was only getting up to 300mbps from wan to lan.
I wanted to check if this was happening with original firmware, so I downloaded correct firmware from TPLINK (Archer C7 v4) and then I've uploaded to router it via SCP to /tmp.
After, i've connected via ssh and executed "mtd -r write /tmp/orig.bin firmware" because "sysupgrade /tmp/orig.bin" was not working.

I was following this how-to

This resulted on bricked device, when I power on leds power for 3-4 secons and then go completly off, I've tried to reset via button but same behaviour.

What happened? How can i recover it?


You need to follow instructions from here:

And here are TP-Link specific instructions:


Did you follow this step?

 An example of an image file with the word “boot” in it is ArcherC7v1_en_3_13_33_up_boot(130729).bin.

Cut the first 0x20200 (that is 131,584 = 257*512) Bytes from original firmware (1*512 Vendor-info + 256*512 U-Boot):

dd if=orig.bin of=tplink.bin skip=257 bs=512

That was my error, I did not made that...
I'll try to recover it like @peternikolow states, ill keep you updated.

Now I'm reading instructions but there it says that to use web firmware recovery, when bricked, power and wps leds should be solid ON. In my case they only are ON like 3-4 seconds and then completly off.

Second link didnt work, but first link, TFTP server worked like a charm. Thanks you guys!!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.