TPLINK AC1750 V4 Serial Resistors/capacitor values [Solved]


#1

I have bricked my AC1750, TFTP will not work. I want to attempt to revive it through the serial. The issue is that the RX/TX have places for resistors and a capacitor that are empty. They are labeled R24,R27,C101. Does anyone know the values of these components for this board?


#2

I'm not sure which TP-Link you have, but https://openwrt.org/toh/tp-link/archer-c5-c7-wdr7500#recovery_using_serial_connection may be helpful in how to use a ~800 Ω resistor to get the serial to behave better. (I have not tried this on a v4 device!)


#3

3


#4

Very different than the Archer C7 v2 in front of me

If I were to guess, and this is only a guess

  • C101 I would guess is for a "bypass" cap on Vdd
  • R27 looks like a pull-down to ground
  • R24 looks like a series resistor in a signal line

It looks very different from the v2 in my hands, which looks like the v2 image at that link

(The chip resistors are not readable on my device)


#5

Thank you Jeff, i may just have to do some trial and error (and get a usb microscope and hot air, i haven't been down that road yet but i guess now is the time to give it a shot).


#6

Just make a bridge in place of R24.


#7

Make a bridge in R24. I had working many serial similar tp-link router and it work without any issues.
On some model, you need connect a 10kohm 'pull-down' resistor on TX pin to ground for stability.


#8

I am also trying to get my serial port working on v4.

In reading the WIKI seems like I need to get some resistors . In looking on Amazon seems that they sell the resistors in different wattage. How would I know the wattage I would need for the resistors for C7 v4

Also I am going to test bridging R24 however is there any risk leaving it bridge ? Without the resistors such as damaging the router or fire ?

The WIKI states the resistors I need just not the wattage.

https://openwrt.org/toh/tp-link/archer-c5-c7-wdr7500

In the lower right is the serial header. The first through hole is TX, second RX and third GROUND. There were two missing resistors at R27 and R24. I placed a 10K on R27 and a 1K on R24 (total shot in the dark based on some reading I had done, but it works). The RX through hole didn't seem to be connected to the right side of the R24 pad so it's got a solder bridge. Use 115200, 8N1, no flow control.

(FYI: from TP-Link engineering, R24 = 220R, R27 = 1K)


#9

Those are "chip" or SMD resistors and carry very little current. They come in varying sizes and, in that application carry very little current (assuming all is wired up properly). An 1/8 W is more than enough, and there is no harm in using a higher-rated resistor (1/4 W, for example) if you're using one with leads.

Soldering SMD resistors is not terribly difficult, but you'll need to carefully measure the size to get it to fit the pads on the board. They're fractions of a cent each through a major component supplier like Mouser or Digikey in the US; it's the $7 or so base shipping that will be the cost. If you do decide to try to solder SMD components, a good set of tweezers, like the utility-grade EROP7SA (US$4.20) and a hands-free magnifier are highly recommended. I use the Donegan DA-5 OptiVisor (~US$40) as a reasonable compromise between magnification and enough room between my nose and the soldering iron or hot-air rework gun (8" / 20 cm focal length).


#10

Thank you all for your help! I finally got around to setting up a breadboard with the mentioned resistor values (R24 = 220R, R27 = 1K), bridged R24 on the board, used my arduino's usb/serial along with putty and it's talking to me, so it looks like there is hope.


closed #12

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.