TP-TL8630P V2.0 (EU) roll back to stock

Hey guys,
i am new to OpenWrt and i thought, it would be a nice idea to flash OpenWrt onto my TP-Link powerline Access-Point.
So i downloaded the file from the device-page (openwrt) and flashed it through Web-UI. Unfortunately there is no WEB-UI (Luci?) nor can i install it (not enough space) so i would like to revert to stock image.
But I have no clue how to do that. I really can't understand what to do with (read through related threads/FAQ)
I do have the right bin file in here C:\Users\XXXX\Downloads\wpa8630pv2_eu-up-ver2-0-3-P1-20171018-rel36564.bin
und i just want to flash this file.
Could you help me?
Thank you very much!!!!

Does this help?


I will try this with Ubuntu VM in tell you this evening (CET) but in don't know what in die there and what the program does...

Hi @rondriano ,

I added a warning about LuCI and stability for the snapshot images to the wiki.

If you want a working build that includes LuCI you can use this one
for the Model: TL-WPA8630P(EU) Ver: 2.0

Follow the instructions here to apply the sysupgrade file.


  • Copy the sysupgrade bin file to /tmp. It might be easier to SFTP/WinSCP the bin file to the router /tmp than using wget if the router is not yet connected to the Internet.
  • Run:
sysupgrade /tmp/openwrt-patch-ath79-generic-tplink_tl-wpa8630p-v2.0-eu-squashfs-sysupgrade.bin

If you want to revert to stock let me know and I can send you the downgrade image generated by the "Reverting to Stock" section tmomas linked above.

thanks so far!
i followed the guide (revert to stock) as far as i could... BUT:
rondriano@ubuntu:~/openwrt/openwrt-imagebuilder-ath79-generic.Linux-x86_64$ staging_dir/host/bin/tplink-safeloader -z wpa8630pv2_eu-up-ver2-0-3-P1-20171018-rel36564.bin -d oem-sysupgrade.bin
No factory/oem image given via -x . Output directory is only valid with -x: Success

thanks, i will try later. First i want to revert to stock.
The TPLink is connected to Internet through Powerline

Sorry, there was a typo in

It should be:

-o oem-sysupgrade.bin


-d oem-sysupgrade.bin
1 Like

it should be ./staging_dir/host/bin/tplink-safeloader -z wpa8630pv2_eu-up-ver2-0-3-P1-20171018-rel36564.bin -o oem-sysupgrade.bin*

Now: How to transfer my oem-sysupgrade.bin to the TPLink ? I have no idea. I know to connect via Putty and with wget i can download files from internet - but how to send data from Linux VM?

btw- i tried to install your version with luci - but after is did "sysupgrade" stuff - i lost ssh connection but could noch connect to webUI ( but ssh works again

You can use "scp" to copy the file from your Linux VM to your router.

scp oem-sysupgrade.bin root@
1 Like

YES! That worked for me! Thank you!
AND!!! All settings have been restored! I wonder why this is.... Are they stored in a partition which i did not override with the flashing?

now i hace to figure out to install openWRT with luci (otherwise it's not really conveniant)

Yes, in the stock firmware user-config partition.

Try this file, which includes LuCI. As mentioned in the wiki, if you get a "Wrong file" message, rename it to something shorter.

If that doesn't work, its probably better to wait until the next stable OpenWRT release comes out, as its very easy to brick this particular device when experimenting with flash images. Or try with a different OpenWRT 19.07 supported router (or PC,Pi,VM etc). It's great when its working:)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.