TP-MR6400 v3 recovery/support

So I recently puchased a TP-link MR6400 for using OpenWRT.
the hardware is apparently at v3, while v1 is supported, v3 is not. i tried flashing the version for the v1, but that did not work. now the unit is "flashing on all led's".

I can still trigger u-boot tftp recovery. but i do not have the recovery image for this device. does anyone know how to get this from the tp-link firmware file?

FYI, the device will try to download "tp_recovery.bin" via tftp from 192.168.0.225, when holding the reset button for at least 5sec while powering on.

Hardware Vendor page
https://www.tp-link.com/uk/products/details/cat-4691_TL-MR6400.html

Firmware Download
https://static.tp-link.com/2018/201805/20180531/TL-MR6400(EU)_V3_180403.zip

Does this help?

https://forum.tp-link.com/showthread.php?81462-How-to-recovery-the-router-when-you-bricked-it

I tried using the official firmware renamed as "tp_recovery.bin" and served it over tftp, but does not seem to work (still blinking LED's). as for the other guide, it would require me to have a valid .bin file. which i currently do not.
I have not started to look for a UART yet.

It fails to load the kernel because the tpink bin is in the wrong format, probably needs some parts of it chopping off or adding.

I'm currently adding support for this anyway, see my post here: Is firmware for TP-Link MR6400 v1 valid for TP-Link MR6400 v2?

After messing around with openwrt on my MR6400 and not being able to get the 4g modem to work, I decided to go back and had the same problem as the OP, tftping the factory tplink firmware does not work. Further investigation reveals that tplink have stuffed 512 bytes of garbage at the beginning of their firmware which needs to be chopped off before it will work.

use the following:

dd bs=512 skip=1 if=tplinkfirmware.bin of=tplink-trimmed.bin

rename it to tp_recovery.bin and it should work.

2 Likes

have you installed this package to get a 4g modem
kmod-usb-core kmod-usb2 kmod-usb-net kmod-usb-net-rndis kmod-usb-serial kmod-usb-serial-option adb

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.