Is firmware for TP-Link MR6400 v1 valid for TP-Link MR6400 v2?

Hi all, i'm new here and it's my first time flashing on router.

I found a small tutorial for installing on a TP-Link MR6400 v1, i have a v2
I tried the firmware but after flashing it i can't navigate to any web interface ( yet mobile module work and it allow to navigate

Should i flash something else or a different .bin?

I need to set QoS on the mobile interface (since have limited GB/month)..

Thank you!!

The v2 isn't supported - only the v1 is listed in the Table of Hardware. I regret to inform you that, if you flashed the router with v1 firmware, your device is likely bricked.[Model*~]=mr6400

Or maybe you flashed the development snapshot, which doesn't have Luci? If so you need to use SSH to configure it.

1 Like

If you can ping your router, most likely in case of Openwrt, then it's safe to say the router is not bricked, but it could have been because you flashed a wrong hardware version.

Well if the router is alive and working and you can ping it, you may need to SSH into the router. Use Putty for Windows and login into the terminal. If successfully logged in through SSH. Then you can install LuCI and further packages.

But if you cant log in to SSH and no web interface is available then your only choice could be to use TTL adapter and login through serial, which is a last resort kinda thing.

1 Like

Hi. Did you solve your problem? i also have mr6400 v2. I plan to flash it with mine.

Still valid:

If you have the MR6400 still, can you open it up and confirm if its running a Mediatek chip and if so what model? You'll see the numbers printed on the chip.

I have tried to load openwrt on the MR6400 v3 and found its the MT7628, not Atheros like the v1. I don't know what the v2 is but suspect its probably MT7628 also. There is no support for openwrt for the v3 either, so I started looking at the boot loader via UART cable.

The flash on the v3 is 8mb, ram is 64mb. The kernel starts at offset 0x20000, and before this is the U-Boot partition.

So I started looking at adding support. Investigating existing TP-Link devices supported by openwrt, the tl-mr3420-v5 looks to be exactly the same hardware including the same flash layout.

I next tftp'd openwrt-ramips-mt76x8-tplink_tl-mr3420-v5-squashfs-tftp-recovery.bin and got the MR6400 v3 booted from this, ethernet and wifi working fine, although the GPIO's are all mixed up causing the LED's to behave erratically or not at all.

I haven't tried going any further with this yet, the next step will be to sort out the GPIO's and see if the 4G module can be accessed.

tftp on the MR6400 v3 looks for tp_recovery.bin at

1 Like

Please note that the TP-LInk MR6400 v4 has a MEDIATEK MT7628 chipset

The question is: What hardware specs does the v2 have, not the v3 and not the v4.

1 Like

You can find here a picture of the inside of a v2 and some technical infos

Continuing the discussion from Is firmware for TP-Link MR6400 v1 valid for TP-Link MR6400 v2?:

Summary: for all intents and purposes, this is effectively the same as v1, with a slight hardware refresh. Ethernet port buffers differ, memory differs (same parameters) and flash differs (same parameters).

v2.1: Serial 2181522....

Looks like Qualcomm QCA9531 (-BL3A)
HJ1801 25Q64CSIG SPI Flash (64mbit flash i.e. 8MB):


Inside the add-on radio card - top:

Inside the add-on radio card - bottom:

EM6AB160TSE-5G memory (512MBit ie 64 MB):


wiki for v1 says J2 is top down:
TX (R29)
RX (R30)

and notes: You also have to shorten R29 and R30 to connect with soc-uart-

Could not get a solid connection without a soldering iron.

Edit 2: Could not upgrade v2 HW from (latest available) factory TL-MR6400_EU_V2_181219 to openWRT - factory firmware quietly accepts the openwrt factory image, but resets your login.

Edit 3: v1 factory image flashes fine onto v2 hardware via TFTP boot method. Device behaves normally, and openwrt image survives reboot.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.