TP-Link WBS510 V1 bricked

Hello. I´m asking for help on how to install the stock firmware on this device.

I was successful installing openWRT 18.02 on this device. I had to return to the stock firmware, downloaded it and installed it via MTD write to the firmware partition. The device rebooted and never came back. The only led that lights up is the power. No TFTP has been successful. Can anybody point me in the right direction to recover this device.

Thanks in advance.


How did you try the TFTP method?

This device is a bit similar, so you may like to try the method described here (but of course with the firmware for YOUR device under Debricking

Thanks for your interest.

No. TFTP doesn't work anymore because ...

"TFTP recovery doesn't work; there is a problem with changed partition settings in the boot loader after OpenWRT/LEDE has been installed."

Any other way?

Thanks again.


No, I don't know about this device more than what's in the link, but the TFTP recovery is mentioned on the OpenWrt wiki, so I imagine this suggests that it should work.

Have you tried placing a switch in the middle as the page mentions?

Yes. The TFTP recovery procedure is damaged after an OpenWRT installation.

Well, your AP isn't mentioned here, but you wouldn't lose much by trying

Next theoretical option would be to try serial recovery, if your device supports it.

I get what you said about the TFTP not working, though I imagine this could only happen if it was the wrong image.

This page have more detailed procedure, in case you wnat ot try again.

My mistake!

I was using the and not the IP address for my tftp server.

The tftp procedure works as defined.



If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

1 Like

And, if applicable, mark the reply with the solution as Solution