TP-Link TL-WR902AC v3 no WAN interface after installation

Hi everyone. Newbie here.

I would like to use my TL-WR902AC v3 with Wireguard to provided wifi to my Smart TV and Firestick. I will use a wired connection from the LAN of my main router (Orange LIvebox) to the TL-WR902AC v3.

The installation went well using TftpTransfer (Mac OSX). The initial setup also went well and I installed all of the Wireguard packages.

My problem is that the installation doesn't include a WAN interface which appears to be needed to complete the final stage of the Wireguard installation. There is a LAN interface but no WAN.

Hope someone can help. Thanks in advance.

Correct, since the device only have one ethernet port.

In openwrt wifi is disabled by default, if the only port was WAN, it'd be very hard to access it.

You can make the LAN port WAN, but then you have to make sure the wifi works,
or you'd be locked out of the device, unless you made some holes in the FW for emergency access.

Thanks so much for the quick reply. So in principle it will work? And provided the wifi works I would still be able to to make changes?

Would you suggest making a WAN interface at the beginning once I'm sure the wifi works or could I do it at the end of the Wireguard installation?

Doesn't really matter.

But I'd make sure internet is accessible (using its wifi) though it, with the ethernet port configured as WAN. Then start the wireguard setup, then there's only one source of error, instead of two.

Remember to use a different subnet on the 802ACs LAN, than on the rest of your network.

Thanks again. Which protocol would be the best for the wan interface?

DHCP client, if you have another router in front of the 902AC.

You've been really helpful. Thanks again. I will post later my results.

No luck, unfortunately. When I delete the LAN interface I can't login even though the wifi was OK before deletion. just gives me the livebox interface not luci. I originally reset the LAN IpV4 to to avoid this conflict but I presume this was deleted along with the LAN interface. Is it possible to somehow set the WAN to

You can set the WAN to whatever you'd like.

If livebox is your other router, then you seem to have the same subnet on both sides of the WAN port, which I told you to avoid :wink:

via SSH do

uci set network.lan.ipaddr=''
uci commit network
/etc/init.d/network restart

now openwrt will respond on

Thanks. I'll just have to quickly learn how to SSH on my Macbook.

the change is doable through webUI too, but for some reason people tend to miss the 2nd force commit the router displays after a 90 (?) sec time out.

I'll need a bit of time to work this out. I'll post back later, thanks.

OK. Here's what I've done:
1 Reflashed the openwrt rom.
2 Executed your SSH .
3 Opened openwrt on and turned on wifi etc.
4 Connected TL-WR902AC to livebox and checked wifi which is OK.

I can open openwrt with a wired connection but when I type in my browser with just wifi I get the message: "This site can’t be reached refused to connect."

I haven't changed anything else (ie tried to delete the LAN etc)

Only reason for it to happen, would be if you're connected to the wrong wifi.
Assuming the 902ACs wifi's up and running, and you can connect to it, it should work.

Which image did you flash, anyway ?

This one

Openwrt appears very, very briefly then I get the above message.

try clearing your browser cache, or try accessing it in incognito mode.

OK. Just tried that and it's still the same.

but you say it works using the ethernet port ?

When I connect the TL-WR902AC v3 directly to my Macbook's ethernet port, yes. (I could connect with wifi when I used the old address).

are you sure you're using the right wifi ?

if your 902AC wifi have the same SSID and pass as the working one, your computer (at least in windows) will disconnect from 902s wifi, because there's no internet access, and connect to the other one.

a way to test it, is obviously to try to access your other router at, while connected.