TP-Link TL-WR845N (Chinese) - no recovery web gui, no TFTP, CH341A not working either

I have on old TP-Link TL-WR845N router (Chinese variant - looks just like this)

Someone made images for the US version, and wanted to try flashing it. Unfortunately, looks like the Chinese version doesn't want to.

I did the whole pressing reset button for 15-20 seconds while connected via ethernet - nothing. Then tried the TFTP method with TFTP64 on Windows - nothing shows up in logs, etc. Then even tried using a CH341A with AsProgrammer - Error connecting CH341(-1)

This is what the motherboard looks like:

And a zoom-in on the chips:

As shown above, there's really only 2 chips can could be tested - but I could only test the one above the long "winbond" chip. The clips cannot physically fit the other one right of that. And I have no de/soldering skills.

I guess this particular router is junk!! :smile:

1 Like
  • Did you try asking that person (i.e. @Heinz)?
  • Are you asking a question for assistance with fixing the device - or just announcing the Chinese version doesn't flash?

If you look up those chip numbers you will find it is 2 MB flash and 8 MB RAM. That cannot work with OpenWrt.

This was common with the Chinese market variants. They run a proprietary non-Linux OS to save memory.


I commented in the thread some days ago. Although @Heinz haven't been seen in over a year.

The former - although doesn't look hopeful.

1 Like

How/where did you do that?

Google ???

1 Like