TP-Link TL-WR1043N/ND v1 wont upgrade

I have problem with upgrading my router TP-Link TL-WR1043N/ND v1 to latest version. I have tried this image and tried from LuCi and with sysupgrade. Upgrade end without error, but after reboot I have still version LEDE Reboot 17.01.0 r3205-59508e3 / LuCI lede-17.01 branch (git-17.290.79498-d3f0685).

Here is output from sysupgrade:

root@gw:~# sysupgrade -i -F /tmp/lede-17.01.4-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin
Image metadata not found
Keep config files over reflash (Y/n):
Edit config file list (y/N):
Saving config files...
killall: watchdog: no process killed
Sending TERM to remaining processes ... dnsmasq ntpd ubusd askfirst logd rpcd netifd odhcpd crond uhttpd
Sending KILL to remaining processes ... askfirst
Switching to ramdisk...
Performing system upgrade...
Unlocking firmware ...

Writing from <stdin> to firmware ...
Appending jffs2 data from /tmp/sysupgrade.tgz to firmware..                                                                                  
Upgrade completed
Reboot (Y/n): y
Rebooting system...
umount: can't unmount /dev/pts: Resource busy
umount: can't unmount /dev: Resource busy
umount: can't unmount /tmp: Resource busy

Any help ?

Thank You

My fault,
I had in /etc/sysupgrade.conf to backup whole /etc/ folder, so file with version openwrt_release was backuped and after upgrade restored with old version values.