TP-LINK TD-W8980 unknown password

Hi folks, I just got a TP-LINK TD-W8980 rather cheap, but the price should have warned me. After power-on the TP-Link web configuration was not accessible, instead only 404 HTTP error with text luci not found or similar. I soldered SERIAL and flashed another firmware (from this video Now I get 403 Forbidden when accesing I tried to log in with telnet but neither root/root or admin/admin works, - I always get bad login reply. Is there any way how to reset root passwod and would should I do next? I will give LEDE a try, but maybe I would end up on TP-LINK 9980 firmware if it is good. (Currently I am using LEDE on another TP-LINK W8970 and it is good.)

What is the URL? usually luci does a permanten redirect, if you plug another device the device will stock firmware will throw a 404 since "" does not exist in their firmware. if you receive an browser login screen then you had stock firmware (luci only ask for login using web form)

have you read info on ?

I tried and yes I was being redirected all the time to cgi-bin/luci, no matter and there I got 404. I tried it several times even with CTRL-F5 to get rid of cached redirect but could never see login page. Anyway I am getting now 403 after I crossflashed firmware from W9980 model as described in the youtube video. I hope there must be a way how to reset root pasword from uboot (probably via bootargs), but even if I get that reset I do not know what to do next. I do not want flash different firmwares blindly. I would like to get rid of problems step by step. Maybe root password is first step. Then flashing LEDE or stock firmware.

Yes I have read the the WIKI, maybe you are pointing to something specific?

admin:admin should word for stock and root:[blank] should work for LEDE.
Did you set a password?
try cleaning cache without having tabs with opened or try using another browser.

I feel so ashamed and happy simultaneously:-) I tried it with Chrome (before it was Firefox) and with only tab and you know it already, it came up with W9980 TP-Link firmware web interface. Still can't believe it, that Firefox could fool me so much. Great, thank you very much.

Password was not set of course.

1 Like

Happy to hear that, You are welcome!