TP-Link RE210 v1: no traffic between port 4 and 6

Trying out a recent snapshot on a TPLink RE210v1 I have thus far not gotten traffic to flow between swith ports 4 (eth0) and 6 (cpu) which reminds me of other such problems related to the move to DSA.

Here's what swconfig tells me about traffic to these ports - traffic to all other ports is null:

Global attributes:
        enable_vlan: 0
        mib: Switch MIB counters


Port 4:
        mib: Port 4 MIB counters
TxGPC      : 37
TxBOC      : 0
TxGOC      : 6710
TxEPC      : 0
RxGPC      : 0
RxBOC      : 0
RxGOC      : 0
RxEPC1     : 0
RxEPC2     : 0

        enable_mirror_rx: 0
        enable_mirror_tx: 0
        pvid: 0
        link: port:4 link:up speed:1000baseT full-duplex 


Port 6:
        mib: Port 6 MIB counters
TxGPC      : 0
TxBOC      : 0
TxGOC      : 0
TxEPC      : 0
RxGPC      : 37
RxBOC      : 0
RxGOC      : 6710
RxEPC1     : 0
RxEPC2     : 0

        enable_mirror_rx: 0
        enable_mirror_tx: 0
        pvid: 0
        link: port:6 link:up speed:1000baseT full-duplex

Notice that there is traffic going from port 4 to port 6 but there is no traffic going the other way.

The switch is configured as default:

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'

I have tried to configure the switch with vlan enabled so as to explicitly link these two ports but this did not make a difference. When the port to this hardware was just released things worked, now they don't. Given that the switch to DSA has caused several related problems on other hardware I suspect this to be one of the possible reasons for this issue.

Has anyone here come across a similar - or this - problem which may give a hint to the solution?

It's not perfectly clear what are you trying to do, what did you tried and the actual problem that you are encountering, can you please elaborate a little bit more on the issue that your device are experimenting?
What happens if you start from the default Openwrt configuration? and which version are you using here?

I'm trying to use the thing as an access point but that does not work when the Ethernet port can not communicate with the cpu... Installing OpenWrt through u-boot works but as soon as it boots it is no longer possible to get traffic to flow from the Ethernet port to the outside or the other way around.

This is the case using the default configuration, nothing fancy added or removed, just a brick with an Ethernet port which you should be able to ping and/or ssh into. It works with the original releases (from ~April last year) but it no longer works with current snapshots. Since OpenWrt is moving towards DSA it makes sense to make sure that it works on all devices in use, hence my experiments with this thing (just like I experimented with it when I got parts of it working when the port was first released). I'm asking whether others have seen similar behaviour on either this device or other devices using similar ramips-mt7620 hardware.

So, to make it clear, here is how it should work:

  1. get a serial connection up
  2. connect the thing to a spare Ethernet port on a PC/Raspberry Pi/laptop/whatever
  3. make the image to be installed accessible through tftp on the PC/etc.
  4. power on, hit '1' in the terminal, fill in the IP data and image name
  5. the thing pulls the image from the tftp server and boots the kernel
  6. the thing is accessible via the Ethernet port, ready to do your bidding, the switch data shows bidirectional data going between ports 4 and 6.

Here is how it works now:

  • 1 to 5: the same
  • 6: the thing is not accessible through Ethernet, the switch data shows only unidirectional traffic between port 4 and 6 as shown above.

The bridge has an address but it never receives anything:

br-lan    Link encap:Ethernet  HWaddr 84:16:DE:AD:BE:EF  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::8616:f9ff:fea2:96dc/64 Scope:Link
          inet6 addr: fd54:b6c4:6541::1/60 Scope:Global
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:79 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:12926 (12.6 KiB)

eth0      Link encap:Ethernet  HWaddr 84:16:DE:AD:BE:EF  
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:98 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:17176 (16.7 KiB)

Have you used swconfig?

The RE210 v1 is MT7620, which does not use DSA yet (only MT7621 does, of the supported ramips targets).

Does latest 19.07 work? Does a 21.02 image work?

There is no 19.07 image for RE210, it is only supported in snapshots (21.02 are snapshot images after all). Neither a freshly-built locally produced (i.e. self-compiled) image nor the downloaded image works.

Yes, I used swconfig as well as ip link, neither of gave the expected results.

mt7620 claims to have DSA but it is not enabled in the build:

$ grep NET_DSA build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/linux-5.4.110/.config
# CONFIG_NET_DSA is not set

My bad, wasn't aware support was added after 19.07. Should have known though when I saw that March 2020 commit date :roll_eyes:

That being said, MT7620 may have that symbol enabled but it's definitely not a DSA target yet:

Any luck on this? Getting the same issue and unable to locate an older snapshot to try.

Added find... if I set my PC to 100-Full Duplex, traffic passes and I can access the repeater via ethernet.

Is there something with the switch driver that changed recently?

1 Like

If I undestand correctly port4 is connected to external gigabit phy. In this case you need setup rgmii internal delay for 1Gbit link.
You can try phy-mode values rgmii-txid, rgmii-rxid and rgmi-id for tx delay, rx delay or tx/rx delays in dts-file.
To try these delay values from phy side you need install phy driver.

This is great!
And the last snapshots are actually way more stable than the previous ones too.

The only big thing missing now is 5 GHz Wi-Fi. I tried to install different driver packages for MT7610/20/XX but no luck. It might require a recompile but I have no experience with that.

Has anyone made any sorts of progress with 5 GHz support ?

This repeater could make an awesome travel VPN router. Just plug it in, connect your laptop to Wi-Fi or Ethernet, and have Wireguard running on it.