TP-LINK EAP 225 V3 (Outdoor) - Failed to check for new Update

Hello guys,

I have recently bought an TP-Link EAP-225 Outdoor (v3) and I wanted to flash it with OpenWRT.

I Found on Firmware selector the following snapshot that I wanted to flash on the device. (

After I followed ofc the steps on the forum here:

I am receiving the following error, when I try to flash the firmware over the Web-Interface:

Failed to check for update.

I tried to flash an older Version of the official tp-link vendor, the v5.0.3 as provided. First of all I couldn't find it and second of all I cannot downgrade with the official images... I receive the same error.

** I also tried to change the name of the .bin file from OpenWRT, but with no success. Also all the files have more than the allowed characters of the image name.

I would appreciated if some1 could help me to solve this kind of issue. Thanks in advance!

I don't have the device (but a v1), so one question:

Please provide the exact steps that you've done, the instructions on the Wiki might not have been clear enough.

Hello andyboeh,

yes, I am going to provide you exactly what I did.

  1. Checked the Version of the EAP and I am on this Version : 5.1.0 Build 20220926 Rel. 62456(4555)

  2. I have been connected with SSH with the device and then

  3. I run cliclientd stopcs

  4. then if I try to upload the .bin file from the web Interface, then I receive Failed to check for new update.

I also tried to downgrade the firmware with the official images but also without any success, so that's why I don't know what left to do.

-> The Outdoor, Wall, EAP225 v3, and later models can be installed via the web interface after disabling FW.

What does FW stands for? Does it mean the third step?

That's a good question and one that I asked myself as well when reading the Wiki article. I usually associate "Firewall" with "FW".

yes but there is no FW option on the AP. :slight_smile:

I don't know what to do and I cannot use the AP with my mesh on OpenWRT...

Not sure if this helps...
Double check that you use the factory bin.
I always had to rename the file as the name was too long - maybe you give that a try?

You could also try an older version of openWRT.
I started with one of the 19.xx.xx (a couple of years ago)

Hello wilcox,

there is no older version for this specific model as 23.05.rc1. I am using only the factory.bin because its the first install and I need ofc in advance to rename the file otherwise it will not be accepted, but nothing worked. I think the problem is with tp-links official image, I cannot also downgrade to an official Version of them...

I followed your link and on the right side I can select the firmware version.
By default it is set to SNAPSHOT.

yes I tried this version first of all. But I receive every time if I want to upload the bin file, "Failed to check for new update"!

I found the firmware that I used in 2021.
Pretty sure not a 23.xx.xx
I will see if I can send it via dm if you want to give it a try.

but is it for v1 of the device or also compatible with v3? Because this plays also a role...

Yes, you are right. :flushed:
I'm just preparing some EAP245 v3 and obviously mixed the names. I'm so sorry! :frowning_face:

its ok, not a problem :slight_smile: You try to help and your suggestions are welcome ofc :).

Could I intercept the http package and trick the tp-links validation rule to accept the .bin file from openwrt?

No idea.
Maybe look if you find a possibility to flash via command line?
Usually there is also a developer thread in the forum.

something like safeloader? or you have an other suggestion?

See here...

Depending on your experience, either hack the image on your own or contact one of those guys to sent you a working file.

1 Like

I cannot find a specific compat_level that he actually wrote down... but I modified the 3 bytes about the firmware version that are needed... I will wait for a response and then I will upload the modified .bin file :slight_smile: