TP-Link CPE710 cannot upload Owrt factory image via gui

Having an issue with the TP-Link CPE710. It's a unidirectional dish and might not have a whole lot of a userbase on Openwrt, but instructions on the device page told me to upload the image through the regular firmware upgrader on the stock GUI. Unfortunately when I do this, the operation invariably fails.

I tried downloading the firmware from 2020- before the device page was last edited, and seeing if a downgrade would allow me to do this. Unfortunately, that didn't work.

On another TP-Link device one of the necessary steps for flashing through GUI was to disable file checks through a command by SSH to upload the Openwrt factory image, but I tried to run this command and it wasn't applicable to this model.

I briefly tried TFTP flashing, but it's hard to know if I failed because of wrong configuration of the server or if it simply did not go into recovery mode. It did not show any difference if it did (eg. Flashing LED). I'd prefer not to have to use TFTP but if necessary I can try again.

TFTP is usually the safest way of flashing, and you should see the file being pulled by the device, during flash initiation.

1 Like

Having used TFTP to flash once before, I've rechecked the basic steps on my PC's end and seem to have it ready to transfer. However, I have no idea how to go about the rest of the steps described here

run a TFTP server
To get to TFTP recovery just hold reset button while powering on for around 30-40 seconds and release.
Stock device TFTP address:
Set ip address of TFTP server to
Put OpenWrt factory image to tftp folder and rename it to recovery.bin
**Stop device while booting in u-boot**
**Run command run flashimg**
**Run command setenv boot_part 1**
**Run command saveenv**

I've never used u-boot before and have no idea how and for the most part what it entails. If anyone could point me in the right direction it would be a lot of help.

You don't have access to uboot.
Just set the correct IP on the host running the TFTP server, disable its firewall, and initiate the flashing, as described in the wiki.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.